Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation since 07/09/2020 in all areas

  1. 1 point
    I don't think you have to download anything. Simply install Unity and Plastic SCM (e.g. Cloud Edition), and then in the Unity Editor Project Settings for the Editor, set version control mode to Plastic SCM. This will enable the feature that draws icons on top of the assets in the Unity project window and lets you checkin file directly in Unity. As far as I know this is already bundled with the Unity installation. There's an Asset Store page titled Plastic SCM that looks like the official plugin, but in fact, the last time I opened it, it was simply an interactive installer for Plastic SCM.
  2. 1 point
    I'm trying to find useful information in the logs, but so far I only found: ERROR PlasticThread - Error when performing background operation: Object reference not set to an instance of an object. ERROR ExceptionHandler - [Application_ThreadException] Unexpected error: Object reference not set to an instance of an object. Also see the attached full log of the few seconds when the error showed. plastic-log.txt
  3. 1 point
    This is now resolved with the help of support. First I checked the config files (it defines the server listening port): C:\Program Files\PlasticSCM5\server\remoting.conf And then the client configuration (that's where the targeting port is located):* C:\Users\<USER>\AppData\Local\plastic4\client.conf* C:\Users\<USER>\AppData\Local\plastic4\profiles.conf These were ok - they pointed it the correct port. Next - Finally, it might be your workspace still pointing to the 8084 port. To solve it:* Open a command line window.* cd to the workspace path.* run "cm ss" to check the target, it might be something like:rep "REPONAME@HOSTNAME:8084" path "/" smartbranch "/main/SCM27239" I ran this command, and my first line simply was "rep "REPONAME"". No host/port. I believe this data is stored in /plastic/plastic.selector in your workspace. * I was told next to run a switch operation to target the right port, something like (you need to adapt this to your scenario):cm switch br:/main/SCM27239@REPONAME@HOSTNAME:8087 This didn't work as I had modified a file in order to test and it complained it wanted me to have no pending changes (and "cm status" wouldn't run because of the original issue in the original post so I couldn't revert that one file). I then ran cm lrep HOSTNAME:8087 which listed my repos on the server so I think we knew at this point it was a workspace-only issue and not a server issue. So at this point - because I knew my workspace had no changes in it since I had checked everything in before the migration - I did this - BE CAREFUL when using this as I believe this kind of a nuclear option. It doesn't delete the files in your workspace - just the meta for the workspace and recreates it I assume. cd "path/to/wks" -> Replace the path with the correct one.cm rmwk . cm mkwk wkREPONAME . --repository=REPONAME@HOSTNAME:8087cm update . This solved my problem!
  4. 1 point
    Hi John, Are you using a WiFi connection? We have seen this error in the past and it comes due to some network issues. Probably using a different network or a wired connection will let you perform the whole checkin. That's why you were able to submit them one by one. Best, Héber.
  5. 1 point
    No, sorry. But I use "grep" in my daily basis. It' a very powerful and useful command regards, Carlos.
  6. 1 point
    Hi, If you just want to search a string in local workspace files you should be able to use a "grep", right? https://www.cyberciti.biz/faq/howto-use-grep-command-in-linux-unix/ Regards, Carlos.
×
×
  • Create New...