Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation since 10/10/2011 in all areas

  1. 2 points
    It is now in 'Developer settings' (settings -> developer settings -> personal access token -> generate new token), but the solution is still working 5 years later ;-). Thank a lot ! https://help.github.com/en/github/authenticating-to-github/creating-a-personal-access-token-for-the-command-line
  2. 2 points
    Hi, when there will be a plugin for WebStorm? IMHO it can't be much work because WebStorm is based on IntelliJ IDEA. Asking greetings Reiner
  3. 2 points
    I've been using 4.1.10.372 - Brighton as a hermit developer on a single workspace for about a year now and recently had to refactor my PC drives and network mapping. The drives on my PC have changed and I would like to change the location of the workspace path. I searched the knowledge base and the forum and didn't see any posts on this subject, but perhaps I'm not searching for the correct terms. Anyhow, I would like to keep the current changeset history but redirect the workspace path. For example: from - F:\MyApps to - G:\Network\MyApplications Thanks -
  4. 2 points
    Hi, I'm hoping someone can help me here to relink my repository and possibly explain how this has occurred. The plastic server has been running fine for over a year with no issues. Today however it has lost our main repository, to be clear all other repositories are still listed in the list of Repositories except our main one. I've had a quick nose around the sql databases and the repositories database repository table also has no entry for our missing repository! There is however a rep_2 database which appears to be our repository. So is there a way I can relink this database into plastic? And any idea how this could have occurred? Any logs I should look at etc... Many many thanks for any pointers.... I'm using version 4.1.10.450 of the plastic server with a MySQL backend.
  5. 2 points
    Hello, Currently running 4.1.10.414, I have questions about shelves. Most of the time (but not always), once a shelf is applied, doing a diff on any of the files contained in the shelf (through the "pending changes" window) report "files are identical" - and that's true, since the file hasn't changed since the shelf was applied. However, what I want to see is the changes since the last changeset in the branch. Once in a while, I get "my" expected behavior. I tend to be really quick on undoing changes on non-modified files, and I'm afraid this will bite me really soon. Similarly, once a shelf is applied in my working directory but not yet checked-in, if I delete the shelf, the diff operation will fail ("an error occurred processing your request") which I somehow expect given the previoius observation - but again, not "my" desired behavior. I'va also noticed than when shelves are applied, files are checked-out, altough I'm not using that model. Is this all due to a configuration option I missed? I'll be upgrading to build 426 soon, but I guess that if this is fixed between those two versions, it's a well-known issue, and someone is likely to be able to point me to a recent public discussions. Thanks, Jean-Marc
  6. 2 points
    Hi I have coupple of request for client improvements: 1) In the list of repositories it would be nice if there was an indicator of workspaces behind in updates (so are not working on the tip). I'm currently working on two places and using sync to synchronize, but besides syncing i also need to set the workspace to the most recent version before starting to work on it. It would be handy if i could see what project need this kind of attention without opening branch explorers for all of them. 2) Activate a workspace when double clicking them (maybe optional) but right-clicking all the time is not that easy to do. and bad for RSI. 3) I would like to see a view with full comments like typed in in the changeset view or in a report vreated from it with multi-line comments (not flattend to a single line). I normally use a (numbered) bullet style. So i would like to see a kind of changelog with changeset numbers, labels and full multi-line comments. Just a exportable report would be fine too. 4) Have an option for some basic formatting in the chec-in comment dialog (bulltets or numbers). 5) Get a warning if you try to close the check-in dialog without checking-in something when there are changes. The current check-in button is far from intuiitive and the current close button is where i would expect the check-in button. The close button should perhaps be named cancel. regards Wim van der Vegt
  7. 1 point
    Hi! We are redesigning the GUIs for the upcoming Plastic 9. And it would be great if you could share with us what are your thoughts about this new design. Read this blog post to check the new screenshots and improvements. Thanks in advance for your comments and suggestions 😊
  8. 1 point
    Hi, I'm afraid the "client.conf" is local client file that cannot be globally configured. Please cehck the following link where we explain all the available files to be globally configured: https://www.plasticscm.com/documentation/administration/plastic-scm-version-control-administrator-guide Regards, Carlos.
  9. 1 point
    I believe you can also remove the file from source control by deleting the file in plastic scm (but keeping the file on disk), checking in the delete, then adding the file to ignore.conf. The file will no longer be tracked and will be removed from your repo. For files you'd like to keep in the repo but you still wish to ignore in some capacity, you'll want to add to the cloaked list or the hidden changes list, depending on your needs.
  10. 1 point
    Carlos, I think this is going to be fixed in BL3799
  11. 1 point
    @jwvanderbeck I do something similar with assigning branches a category and there's 2 ways I've found to have that show up in Branch Explorer without using colours: In the right hand pane where you can select Display Options, there's an option to 'Display branch task info' which displays the branch description (comment field) after the branch name. Eg, you could have a branch named 'task0001' with its description/comment as '[feature] implement cool new feature' and both will show up in Branch Explorer. Alternative option if you can't use the above, is to use a long branch name. Eg, you can name the branch something like the following. This works fine if you just use GUI/scripts, but not a great idea if you use 'cm' console command to do stuff with branches... task 0001 | [feature] implement cool new feature
  12. 1 point
    Did you find "checkin to different branch"? Or, move cset to a different branch:
  13. 1 point
    This is the same behavior using Xlinks or not. The "cloaked.conf" rules are applied only if the file is already in the workspace before you run the update. If the "cloaked.conf" file is downloaded during the update from the repo, I'm afraid the rules won't be applied during the initial update (but they will do the next time because the "cloaked.conf" will be already in your workspace). Regards, Carlos.
  14. 1 point
    Hi, If I properly understand, C is the parent repo that has Xlinks pointing to repos A and B. I'm able to create some cloaking rules in the C repo applied to the Xlinked content. I can do it via GUI --> right-click --> Add to the cloaked list. Then, If I create a new clean workspace pointing to C and before updating, I copy my previous "cloaked.conf", these files are not downloaded to the workspace. Remember that these cloaking rules apply to Xlinked content. In summary, I'm not able to reproduce your issue. Are you using the Windows Plastic GUI? Could you attach some screenshots and your "cloaked.conf"? Regards, Carlos.
  15. 1 point
    Hi, we have been using Plastic Cloud + Jenkins + Unity up until a few months ago. Support staff may have better answers, but hopefully this will get you going: This is happening because Jenkins is by default not running as your local user, but under the Local System account. C:\WINDOWS\system32\config\systemprofile\appdata is the %APPDATA% folder for the Local System account. You can change which account is used when launching Jenkins if you want to. Change these settings by starting the "Services" function in Windows, locating the Jenkins entry in the long list, and editing its properties. Ideally you should create a separate account (probably named "Jenkins") and run the Jenkins service under that. The config file location will then be C:\Users\Jenkins\AppData\Local\plastic4\client.conf. You need to ensure that two files exist in the config dir: "cryptedservers.conf" and one "*.key" file. You can copy the cryptedservers.conf / *.key file pair from your local user's Plastic folder. It is also possible to create these files programmatically, but that's a fair bit more work. 1+ year ago there were no hooks available in Plastic Cloud. We configured Jenkins to poll with 2-minute intervals - that was good enough for our purposes. The syntax to do so is to give a schedule like "H/2 * * * *" in Jenkins. ---- You may also find these references useful: Automation scripts for setting up and deleting Jenkins build slaves, for a Plastic/Jenkins/Unity build system: https://github.com/falldamagestudio/JenkinsAutomation Performance profiling results for a Jenkins build system: https://blog.falldamagestudio.com/posts/performance-optimizing-a-small-build-system-for-unity/
  16. 1 point
    Hi, so I copied all data from E:\ to E:\jet and changed the jet.conf file. No Plastic starts without problems. So it seems like only Drive Letter as path is not working with newer Plastic versions. Can an admin mark this thread as solved, please? Thanks for your help! Thomas
  17. 1 point
    Sorry for the delay. I haven't used Plastic with Visual Studio nor upgraded since I installed Plastic. I haven't been getting this issue in the past 2 months, but I didn't do anything of note to fix it. One thing that has changed is the team's server was apparently locked by Plastic at one point for some reason, and we got it lifted. I'm not sure if that is related or not.
  18. 1 point
    Serves me right for not keeping on top of the change log. So far it seems to be fine. Thanks!
  19. 1 point
    You can use the --cset option to get the output in the original cs:X@repository@server format: c:\mcga>cm status --cset cs:8@rep:test@repserver:localhost:8084
  20. 1 point
  21. 1 point
    Hi @tucny, You can create a top-level branch from any changeset using the command line (I don't think you can specify the changeset in the GUI though). This means you could create a new top-level branch from changeset 0, and it would be empty. See this forum post: Obviously being in the same repo means making changes to V2 will increment changeset numbers for V1 (not sure if you care about that). Alternatively, you could do a hybrid approach of what Pablo suggested. Replicate the entire V1 repo into a separate V2 repo. Then use the above approach to create the top-level branch from changeset 0 (inside the new V2 repo, keeping the V1 repo unchanged). Kind regards David PS: I personally label all changesets on main (eg, label M-1, M-2, M-3 etc), which you can automate with triggers. I find this easier than referencing cs:id numbers, which aren't visible in branch explorer and which can also differ across replicated servers when working distributed (meaning you have to refer to them by GUID, which is not easy to read or type). Main downside is it makes things look a bit busier, and if you use labels for releases then those no longer stand out as much (unless the Plastic team also introduce the ability to colour code labels and/or changesets by attribute or custom filter rules *wink wink nudge nudge* @psantosl).
  22. 1 point
    Yes, I'm afraid at the moment "comment "is not available in the format field. We could include it as a feature request. Regards, Carlos.
  23. 1 point
    Nice. I never had an occasion to create a subrepo, that makes sense. Thanks! Regarding Jet...it sounds great for speed but I like the transparency and accessibility of SQL Server (being able to use TSQL). I've had minor issues in the past (regarding dangling workspaces when clients were removed without removing their workspaces) where directly modifying the data for a workspace in the SQL table fixed the problem (this was a few years ago). Not having the ability to query/modify Jet data could be an issue. At least with SQL I know that I have an extra layer of visibility into the underling storage system so that if anything goes wrong (corruption for example) and I don't have a recent enough backup for some reason (or a backup wouldn't help, like in my above problem) then I still can potentially fix the issue. The completely closed nature of Jet keeps me relying on my trusted SQL server. Do you have Jet tools (even command line would be fine) that allow for query/update capability if needed? Or do you publish the Jet structure/standard anywhere?
  24. 1 point
    Sorry, I'm afraid the macOS GUI doesn't include this option in the right-click menu The guide is based on the WIndows GUI. If you are both using macOS, the permissions can be configured by "cm acl --help" command. Please reach us at support@codicesoftware.com and we can arrange a training session with you. Regards, Carlos.
  25. 1 point
    Hi holikri, we will take the case to our support team to evaluate it and give you a response asap We are sorry for the inconvenience. Thank you! Francisco
  26. 1 point
    Hi Sam, If you are a customer, please always reach us at support@codicesoftware.com for a faster answer. There shouldn't be cached information in the GUI client after restarting it. If you drive to preferences, are you able to "check connection" with no issues? Are you configuring your client entering the server name (or IP)? Could you send to our support email your client log? C:\Users\<user>\AppData\Local\plastic4\logs\plastic,debug.log.txt If you re-enter the line in your client host file, doesn't it help? Regards, Carlos.
  27. 1 point
    Hi there. I've seen quite a few reports of this similar message on the forum: "Checkin operation cannot be started because there is a merge in progress. Finish it before checkin the changes. In progress merge. Merge from cset xxx." But I still don't know what to do about it, and my colleagues bang their heads into the same problem. We can't check in but who knows how to do this merge? Sometimes while we can't do it in Visual Studio it works in the client app, but sometimes that doesn't work either. The only cast-iron solution seems to be to undo everything losing all changes, then update workspace and try again. There's a real logical problem to this since there doesn't seem to be any option to merge these changes. It seems in v3 the merge happened immediately but now it's being deferred and then breaking the checkin. Is there some real foolproof guide to how this should be working now? I can't even work out what it is that's going on, what the problem is, how to guarantee to solve it. Our designer to use Plastic too and he really doesn't know what he's doing, but at least v3 seemed logical and simple. None of us know what to do to solve this problem in v4. I've attached a screenshot. This is from our designer. He's not even aware of any merge. He just tried to make a small change to the existing workspace, but presumably his workspace was out of date when he came to check in. (It's difficult to persuade him to start a new branch to make one tiny change, and to be honest that seems like overkill to me too, otherwise we're going to end up with hundreds of branches filling up the branch list and getting in the way. Until there's a way to archive completed branches it's not something I want to do anyway.) The question is, how do you "finish" a merge? There doesn't seem to be any button or option to do that. Thanks.
  28. 1 point
    I think that repro is simple - I've marked this toggle in options few days ago and pending changes get destroyed. Maybe that when pending changes are "destroyed" Options window values overrides cfg file or sth like that.
  29. 1 point
    Great to hear that! Anyway, it seems that it's something that we can improve when searching ignored items... Thanks for the feedback!
  30. 1 point
    Ignored changes was set to false in config file but not in Options! Pending changes now works great! After rechecking cfg file I've checked it in PlasticGUI (Pending changes -> Options). In "What to show" tab "Show ignored changes" was checked. Dunno if it's bug that toggle in options overrides value in cfg but now its working!
×
×
  • Create New...