Jump to content


Popular Content

Showing content with the highest reputation since 11/24/2019 in all areas

  1. 2 points
    Hello, Have you manually moved the "client.conf" to this path? By default, it shouldn't be there. Anyway, assigning the necessary permissions to the file should prevent this error to happen. Regards, Carlos.
  2. 2 points
    We're starting the development of the next GUI (called GUI 9 internally) in the next weeks. We expect having time to refactor the dark theme and implement a proper one.
  3. 2 points
    Hi, We just changed this behavior. There is a fix ready that will be shipped in the next public release. It will be reday today or early next week. We apologize for the inconvenience.
  4. 2 points
    Hey, just thought I'd say thanks to the devs and support team for the good job you guys are doing. Plastic has been easy to use for the most part and the support team has always been quick to reply when I've had questions. Keep up the good work! (This message was not paid for)
  5. 1 point
    Hi, We normally keep the databases a few days (so you can recover a deleted cloud repo) but after a week the usage value will be refreshed and the databases fully removed. Regards, Carlos.
  6. 1 point
    Hey Carlos, I spent this morning migrating to a new workspace, so the problem is solved. Anyway thanks for your attention
  7. 1 point
    Hi, You can create a "after-ckeckin" trigger so the sync command is executed inside the trigger. Please check: https://www.plasticscm.com/documentation/triggers/plastic-scm-version-control-triggers-guide Regards, Carlos.
  8. 1 point
  9. 1 point
    \o/ It's working now But I don't got what I was doing wrong, differences between your setup and mine is only your binding that is to "Repositories" and not my local repository specifically Anyway, thanks for help 😜
  10. 1 point
    Hi Xavi, These are the answers to your questions: 1.- I guess you talk about Cloud Edition. We consider an active user, a user registered in the cloud organization that makes a write operation (check in) or download more than 5 MB. 2.- In Cloud Edition, you start paying from the fourth active user in the last 30-day period 3.- There is no limit. Consider that you will considered an active user if you donwload more than 5 MB. 4.- The payment is composed of cloud storage and users. The price is free up to 3 users and includes 5GB of cloud storage. From the 4th user, the price is $7/month per active user (if a user doesn't access the Cloud for one month, you are not billed for that user). Once you exceed the 5GB, the extra storage is paid per organization, not per user. The price is $5/month per team for up to 15 GB, $20/month per 100 GB, and $7 for every 50 GB above per month. I hope it answer all your questions. Regards, Angel
  11. 1 point
    I think he's describing a feature like Microsoft Symbol Server, that stores metadata of every binary generated and can later link it to a given set of binaries. We don't do that (at least not yet), but it is very easy to embed the cset number (the GUID) to the exe during build 🙂
  12. 1 point
  13. 1 point
    We have upgraded the plugin to 3.4 and I'm happy to report that the issue has been fixed and the command now succeeds! We are also still able to get the output ot the cm command by assigning the output to a script variable inside the Jenkins Pipeline, so as far as I can see there are no breaking changes introduced by this change. Thanks a lot! I consider the issue solved.
  14. 1 point
    Hi, The following tasks change the way were processing the XML output. https://github.com/jenkinsci/plasticscm-plugin/pull/36 https://github.com/jenkinsci/plasticscm-plugin/pull/37 They are not still public (most probably later this week) but I think they should fix your problem. Regards, Carlos.
  15. 1 point
    Hi, You can use GitSync to migrate the repo. If you don't plan to sync the repo again in the future, you can revert this status by deleting the gitsync mappings for that repo and the Gitsync attribute created in it (check the attributes of the repo in Plastic GUI). The mappings path is: C:\Users\xxx\AppData\Local\plstic4\sync\git After removing the mappings folder and the gitsync attribute, the Plastic repo won't be related with the git repo anymore and you will be able to remove the Plastic changesets. PD: We don't allow to delete changeset by default in a repo synced with git because it may break future sync operations. Regards, Carlos.
  16. 1 point
    Hi, Good news: we fixed the issue and the patch will be included in a future release (I estimate someday in the next week). You can look for it in the release notes. Thanks for reporting!
  17. 1 point
    Hi, The local repos in Plastic Cloud edition are stored by default at: C:\Program Files\PlasticSCM\server\jet Regards, Carlos.
  18. 1 point
    Dear Plastic SCM Community Member, Are you interested in helping Unity improve its merging and collaboration tools? We are recruiting participants for a 1-hour usability study between September 9 - 15. We are looking for participants who have experience working in Unity as a part of a team. If you are interested in participating, please take this quick survey to see how you meet our target audience. We are excited to hear your valuable feedback. Thanks! https://unitysoftware.co1.qualtrics.com/jfe/form/SV_6uvDDpWU8F1o6Md Thank you, Alyssa from the Unity UX Team
  19. 1 point
    Yeah, that's my opnion. They don't look like any normal buttons, just titles. Either they should look more button-like, or the message should be reworded to make it clear what it's referring to "by clicking on the Deselect buttons".
  20. 1 point
    Hi, We have released the following task: [Bug ] All platforms - Plastic, Gluon: We fixed an unexpected error while detecting refreshing views in Cloud Editon. Some customers reported an "unexpected error" when refreshing certain views. We were able to reproduce it in one computer refreshing the Branch Explorer. It was a concurrency problem in setting a local member in a class. That code is now protected, an the problem gone! Regards, Carlos.
  21. 1 point
    I finally resolved the issue I was having. I checked literally everything. Firewall, ports, possibly antivirus, possibly a service causing the issue (had those before). Found nothing. After I did a fresh install of Plastic SCM on a VM, I found out that in my preferences there was no connection profile. I can't remember adding a connection profile, as I've only created a repo, check-ins, and sync views, but probably did on a drunken night. Upon deleting the connection profile, I have no problems connecting to my cloud repos now. If anyone is having this particular issue and how to find the connection profile: Preferences > Connection Profiles. I appreciate you replying to my post, Carlos, but in the end it was my connection profile which most likely wasn't added correctly.
  22. 1 point
    Hi, We are handling this topic and other solutions to reduce the database size in the following link: Regards, Carlos.
  23. 1 point
    I don't think you have to download anything. Simply install Unity and Plastic SCM (e.g. Cloud Edition), and then in the Unity Editor Project Settings for the Editor, set version control mode to Plastic SCM. This will enable the feature that draws icons on top of the assets in the Unity project window and lets you checkin file directly in Unity. As far as I know this is already bundled with the Unity installation. There's an Asset Store page titled Plastic SCM that looks like the official plugin, but in fact, the last time I opened it, it was simply an interactive installer for Plastic SCM.
  24. 1 point
    Wanted to add this here because it's the hit that comes up when you search for this issue. I had this issue as well, and for me it was due to copying an existing project that had a repo/workspace in Plastic to a new directory. I did not know it, but there's a hidden .plastic directory. It saves information about the workspace. Since it was copied into the new project, it confused Plastic and caused this erroneous claim about the workspace. The solution was deleting the .plastic folder in the newly copied project.
  25. 1 point
    This is now resolved with the help of support. First I checked the config files (it defines the server listening port): C:\Program Files\PlasticSCM5\server\remoting.conf And then the client configuration (that's where the targeting port is located):* C:\Users\<USER>\AppData\Local\plastic4\client.conf* C:\Users\<USER>\AppData\Local\plastic4\profiles.conf These were ok - they pointed it the correct port. Next - Finally, it might be your workspace still pointing to the 8084 port. To solve it:* Open a command line window.* cd to the workspace path.* run "cm ss" to check the target, it might be something like:rep "REPONAME@HOSTNAME:8084" path "/" smartbranch "/main/SCM27239" I ran this command, and my first line simply was "rep "REPONAME"". No host/port. I believe this data is stored in /plastic/plastic.selector in your workspace. * I was told next to run a switch operation to target the right port, something like (you need to adapt this to your scenario):cm switch br:/main/SCM27239@REPONAME@HOSTNAME:8087 This didn't work as I had modified a file in order to test and it complained it wanted me to have no pending changes (and "cm status" wouldn't run because of the original issue in the original post so I couldn't revert that one file). I then ran cm lrep HOSTNAME:8087 which listed my repos on the server so I think we knew at this point it was a workspace-only issue and not a server issue. So at this point - because I knew my workspace had no changes in it since I had checked everything in before the migration - I did this - BE CAREFUL when using this as I believe this kind of a nuclear option. It doesn't delete the files in your workspace - just the meta for the workspace and recreates it I assume. cd "path/to/wks" -> Replace the path with the correct one.cm rmwk . cm mkwk wkREPONAME . --repository=REPONAME@HOSTNAME:8087cm update . This solved my problem!
  26. 1 point
    Hi John, Are you using a WiFi connection? We have seen this error in the past and it comes due to some network issues. Probably using a different network or a wired connection will let you perform the whole checkin. That's why you were able to submit them one by one. Best, Héber.
  27. 1 point
    No, sorry. But I use "grep" in my daily basis. It' a very powerful and useful command regards, Carlos.
  28. 1 point
    Hi, If you just want to search a string in local workspace files you should be able to use a "grep", right? https://www.cyberciti.biz/faq/howto-use-grep-command-in-linux-unix/ Regards, Carlos.
  29. 1 point
    Hi, We have released the following task: [New] Issue tracer extensions - JIRA: Next-gen projects now supported Next-gen projects do not support the type of custom field we use for the JIRA integration. To resolve this, we have added the option to have the checkin info added to the JIRA issue as a comment. Leave the "Custom field ID" blank in your Plastic Issue Tracker configuration to have checkin info added as a comment. Regards, Carlos.
  30. 1 point
  31. 1 point
    Use DateTime.ParseExact.- Converts the specified string representation of a date and time to its DateTime equivalent using the specified format and culture-specific format information. The format of the string representation must match the specified format exactly. ParseExact and TryParseExact allows to use a custom format string. DateTime date = DateTime.ParseExact(strDate, "dd/MM/yyyy", CultureInfo.InvariantCulture); The IFormatProvider parameter specifies the culture to use to parse the date. Unless your string comes from the user, you should pass CultureInfo.InvariantCulture. If the string does come from the user, you should pass CultureInfo.CurrentCulture, which will use the settings that the user specified in Regional Options in Control Panel.
  32. 1 point
    Thanks - that seems like a workflow which would work for my use-case. However, since we are using plastic cloud - I can't use shelving . I'll reapply my changes manually for now. Which can also be a step where code quality can improve, because I'm now recreating/reintroducing the end result while knowing where I am going. But when shelving gets supported for cloud I'll try it out
  33. 1 point
    I shared this request with the team. We already internally commented some improvements about how the user can fine tune the move detections performed by Plastic. It would be a nicefeature but I'm afraid it's not scheduled for the near future. Regards, Carlos.
  34. 1 point
    You can do it with the current UI: First, use click + shift-click to mark a range of files. (You get a blue box type mark over each of the marked files.) Then, click in the checked/unchecked-boxes next to one of the marked files. All files the marked files will change their checked/unchecked-status to match that of the file whose checked/unchecked-box you just changed.
  35. 1 point
    Hello. All 3 of our development devices have a fast SSD and a HDD (or slow SSD) and we always used symlink to move databases to secondary drives to save space in primary drive. We didn't have any problem because of that. But of course I would prefer a native support.
  36. 1 point
    Hi Carlos, Thanks for the quick reply! I got it working now, thanks for pointing me to the correct docs. I was looking in the Administrator's Guide at https://www.plasticscm.com/documentation/administration/plastic-scm-version-control-administrator-guide#Chapter16:Configurationfiles which only has a brief overview for filetypes.conf and no link to the book. Cheers, -- Aki
  37. 1 point
    Never mind, i decided not to use this plugin. Shared libraries work fine with Plastic!
  38. 1 point
    Hi, In macOS, the user local configuration folder is stored at: /Users/xxx/.plastic4/plastic.workspaces Regards, Carlos.
  39. 1 point
    Thanks Carlos, I think you might be right. I changed the preference and based on a few spot checks, the problem seems to go away. I should have thought of that! I guess checking the hash is slightly slower but it doesn't seem to matter for our repo size.
  40. 1 point
    This is the first time we see this porblem so far. We will try to schedule a task to protect this scenario but most probably it won't be avilable for the near future. Regards, Carlos.
  41. 1 point
    Hello Carlos, Thank you for listening to your customers' feedback! This is great and hopefully makes Plastic better. Cheers, Francois
  42. 1 point
  43. 1 point
    Hi, You can also use the "cm replicate" command to just replicate the specific branch. If you are using the sync view, you can play with the text filter and the exclusing all the branches you don't want to sync. For excluding the branches, you should be able to also manually edit the configuration file (instead of doing it via GUI). Not sure if it helps. Regards, Carlos.
  44. 1 point
    I like a lot of the changes that you are planning. Here is one thing that I have noticed with the current design, which I'm not sure whether the new design improves upon: I have found it strange that all tab-views have to exist within the context of a workspace. Whenever I work with Plastic I often end up with a tab list like this: The first three tabs are related to the current workspace. So far so good. The last three tabs are entirely unrelated to the current workspace. I wanted to browse the history of an unrelated repository - but the only way for me to do so, is to open a "Cloud repositories" tab, and subsequent detail views for the cloud-side repository, within the current workspace's view. I keep doing this a lot. I keep cleaning up my tab list (carefully) a lot. The first thing that feels unnatural to me is that "Cloud repositories" opens as a tab within a Workspace view. The second thing that feels unnatural to me is that if I begin to drill down into another repository, the additional tabs continue to open up within a Workspace view. If there was a way for me to get a new view - possibly in the top-left workspace selector - which is tied to the (serverside) repository I have chosen, and not to any workspace, then I would set up a couple of tabs within that view, I would keep that view around for a long time. ========================================================= Summary: I would like to be able to create workspace-less views. For example, imagine that there was an "Open repository" alternative at the bottom of this dropdown: The "Open repository" option would ask me to choose a repository, either on my local server or on the cloud side. After choosing a repository, I would then have access to a subset of tabs within that view (only the tabs that make sense when browsing without an associated workspace). I would set up a couple of these workspace-less views, for projects that I don't actively work on but follow discussions on, and keep those views for a long time. This would reduce the amount of time I spend creating & cleaning up tabs.
  45. 1 point
    These changes but good! But I do have to say as an end user the GUI is not the painful part of Plastic, but rather unexplained/strange conditions. Any effort to address error states/messages better would be an even bigger win, in my opinion. Just these 2 we brought up here for example: Renaming a branch causes other workspaces referencing it to "break" without explanation (just error messages) "Hidden changes" causing a warning that looks unrelated, every single time you switch workspaces (even if having changed files locally is the intended usage pattern for hidden changes!) Also not being able to use shelving for cloud users would be nice. Anyhow, we really like how you're being responsive again these are meant as constructive criticism. Thank you!
  46. 1 point
    It is now in 'Developer settings' (settings -> developer settings -> personal access token -> generate new token), but the solution is still working 5 years later ;-). Thank a lot ! https://help.github.com/en/github/authenticating-to-github/creating-a-personal-access-token-for-the-command-line
  47. 1 point
    Hello, We are trying to use Plastic SCM as a Git Server. We are able to connect to it via SourceTree. Items in red are censored from the real information. The file I'm trying to add is a text file with 4 characters in it. SourceTree error: git -c diff.mnemonicprefix=false -c core.quotepath=false push -v origin feat/Test:feat/Test Pushing to git://Computer:9418/repo Looking up Computer... done. Connecting to Computer(port 9418) ... X.X.X.X done. error: remote unpack failed: An error was raised by libgit2. Category = Odb (Error).? Invalid pack file - base entry delta is not in the same pack fatal: protocol error: bad line length character: Git push via cmd: Counting objects: 3, done. Delta compression using up to 8 threads. Compressing objects: 100% (2/2), done. Writing objects: 100% (3/3), 277 bytes | 277.00 KiB/s, done. Total 3 (delta 1), reused 0 (delta 0) error: remote unpack failed: An error was raised by libgit2. Category = Odb (Error).? Invalid pack file - base entry delta is not in the same pack fatal: protocol error: bad line length character: Any thoughts as to what I may be doing wrong? Regards, Aaron
  48. 1 point
    bump, I just ran into this for lots of files, quite painful
  49. 1 point
    How come you cannot shelf changes in PlasticSCM Cloud when using Direct Check-In?
  50. 1 point
    Related to your situation: We decided to train everyone on our team (progammers, designers, artists) to use the full Plastic SCM client. We are working against Plastic Cloud. We are missing out on the simplicity of Gluon, and we are not using exclusive checkout at all, but it has worked out well for us. Our process for a new developer is like this: 1. Begin by working directly against the main branch. Focus on the "Pending Changes" and "Branch Explorer" views. Do the first couple of check-ins in pairs until the developer is comfortable with checking in. Programmers typically work against the main branch for a day or so, and then they go straight to task branches. Artists and designers typically work against main for 2 weeks - 2 months. After that, they are ready for step 2. 2. Talk with the developer about how he/she are doing single, large check-ins because the developer is afraid of breaking things for others - and how the developer sometimes loses local work (typically through mistakes in the editor when making a large change, etc). Talk with the developer about the conflict ("check in often is good: backup & share results" vs "don't break the build"). Talk with the developer about how there currently is no way for him/her to share results between two people or two machines (say, work machine + home machine) without also sharing it with everyone else on the project. 3. Set the developer up with a personal branch. Talk with developer about how checking in and merging now are separate steps; checking in to a separate branch only has upsides, and no downsides; merging is where care needs to be taken. Do the first couple of merges in pairs until the developer is comfortable with merging. Explain how "merge from main to your branch often" makes merging back less complicated. Explain how the "merge down from main, then merge up" philosophy makes merging less complicated. Some of our artists choose to stop at stage 3. They want to work with personal branches. Those who want to move on, are ready for that after 3-6 months. 4. Talk with the developer about how their feature work is task oriented but how that structure is not reflected in the Branch Explorer - it's difficult to see where one effort ends and another ends in the project history. Explain the concept of "task branches". 5. Train developer in creating new branches for each major task. Small stuff can still go straight into the main branch. Discuss how to handle multiple overlapping tasks. Discuss how per-task branches help them organize their own work. We have all our programmers, 40% of our artists and 50% of our designers using per-task branches. Remaining developers have personal branches.
  • Create New...