Jump to content

Andrew Carvalho

Members
  • Content Count

    3
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by Andrew Carvalho

  1. Serves me right for not keeping on top of the change log. So far it seems to be fine. Thanks!
  2. Recently the plastic GUI started prompting me to sign in with the first time onboarding process the first time I launch plastic every time I boot my machine. This may have happened around the time where the cloud page (I am a cloud user) were integrated into the main page. If I get far enough to where it prompts to create a default workspace, then exit out early and relaunch, it boots with my last configuration. Some additional info info in case it is useful: My client.cong file in appdata has secutiryconfig, current workspace, etc configured. I am a member of two different organizations (one for my own studio and one for a client I am running v8.0.16.3189 Sometimes I can boot as expected without seeing the login screen. Minimal testing shows this seems to happen (but not consistently) if I log into the plastic site (I think specifically the forums?) before launching plastic. This is fuzzy but I haven't had the time to investigate further. Clearly I can work around this for now but I'd love some help figuring out why this is happening and it's very mildly annoying.
  3. I am using Plastic Cloud and have recently moved from connecting directly to the cloud to a local replication. There are times when I am working when I don't have internet (I commute a good portion some days and usually catch up on work) or when my internet connection is spotty. It's something I have wanted to do for a while but help off on due to reliance on exclusive locks. However, I decided to investigate if there was a solution to this and came across this blog post and how the lock.conf file can be placed beside the server executable to redirect lock requests and checks to another server. I've created the lock.conf file but am unsure how to point it to our cloud. I have tried rep:[out_repo] lockserver:[our_org]@cloud:8084 but it does not work as I'm not sure if the server will automatically expand the @cloud shortcut. I've also tried port 8086 as it was mentioned in the Cloud guide. Though the guide mentions lock.conf being hot-reloaded, I restarted the service just in case to make sure that wasn't the issue as well. What would be the appropriate way to setup my local lock.conf to use plastic cloud as the lockserver? Is this not currently possible? If not I will likely move back to a centralized system (which had no issues other than needing that pesky internet connection). I'm aware the locks won't work if I am working without an internet connection but as I am usually connected and really just want the distribution for the odd time I'm not, I'm okay with this. Bonus question: if I am redirecting my locks to a different server, do I still need to list all the patterns in my local server? I have them in the file currently but wasn't sure if it was necessary. Andrew
×
×
  • Create New...