Jump to content

Search the Community

Showing results for tags 'certificate'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Plastic SCM
    • General
    • Installation and configuration
    • Unity 3D
    • Plastic SCM on Mac
    • Plastic SCM on Linux
    • Gluon
    • Git interop
    • Integrations
    • Community Edition
    • Branching and merging
    • Announcements
  • Plastic SCM 4.0 Beta (Closed)
  • Plastic Cloud
    • General
    • Configuration
  • SemanticMerge
    • General
    • License
    • SCM's configuration
    • Share your experience!
    • External Parsers
  • GitJungle
  • Method History for Subversion

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 3 results

  1. I am on Windows 10 and I regularly get this pop up when I open Plastic. I removed the hostnames from the message I pasted above for security reasons. The only way I recover from this is to go to C:\Users\<username>\AppData\Local\plastic4\ folder and delete the guivisualstate.xml file. Evidently this has something to do with server certificates etc. There is an outdated help page which asks you to create a self signed certificate using makecert but there is no makecert anymore in Windows 10. See this thread We need to use New-SelfsignedCertificate See thread https://docs.microsoft.com/en-us/windows/win32/seccrypto/makecert Can someone help me? I am going crazy with this issue and I have been living with it for 2 years now.
  2. Hello everybody, I suddently have a problem with one of my Plastic SCM client on Windows. Everything worked well, but since last week I can't connect to my Plastic server anymore. Nothing changes in server config nor in my client config, but now I've got this message "The remote certificate is not valid according to the validation procedure" (see attached picture). The server has an attached domain with a valid, not expirated, certificate. But, as my client is on the same network as the server and as my box can't do loopback (domain name pointing to itself) I have an entry in my client host file to redirect domain name to local server IP address. This worked for more than 3 years without problem. The only thing that happened last week is that I used my PC out of office, so I removed the redirect line in my client host file in order to do my commit through "real" internet. This also worked properly. But a few hours later when I restarted Plastic from my office again (with local host redirection), it began to display the error message. Server and clients were in version 7.0.16.2604, I updated my Windows client to 8.0.16.3068 but the problem did not disappear. Two other clients (on Mac) don't suffer from the problem and continu to reach the server without problem, locally or through internet. So my question is : is there a kind of certificate cache on Windows client ? ... Perhaps wrong data was cached when I came back to my office. I tried to clear windows ssl state in "internet options" but it had no effect. Any idea ?
  3. Any idea how to solve this problem (short of turning off SSL connections)? I want to perform a cm crt on a file listed as binary when it should be listed as text - so I created a batch file to run it for all such files. When I actually installed and named the server, the server name is as displayed in the cert line below - Plastic01 with capital P. The GUI works fine, and all of the .config files actually have it specified with a capital. -- the command line lists the server name in lower case. WARNING: the secure connection hostname provided in the server certificate doesn't match the server's hostname. This means that the certificate was not issued to this hostname or that there is a network configuration problem with this host. - Certificate hostname: CN=Plastic01.gohealthcast.com - Server hostname: CN=plastic01.gohealthcast.com If you want to continue connecting to this host, choose 'Yes'. The certificate validation will continue (not recommended). If you want to abandon the connection, choose 'No' (recommended). Choose an option (Y)es, (N)o (hitting Enter selects 'No'): no matter what option I use, it prompts with this message for EVERY file - even when I confirm to use it anyway, I get this message The server you are connecting to has sent a certificate that is not in the store. This is normal if it is the first time that you connect to this server. Certificate details: - Issued to: CN=Plastic01.gohealthcast.com - Issued by: CN=Plastic01.gohealthcast.com - Expiration date: 3/21/2023 5:20:13 PM - Certificate hash: 7B1FA6D79BB4C567C30EE5DD23CCC24D0670EA71 If you trust this host, choose 'Yes' to add the key to Plastic SCM's key store (recommended if it is the first time you connect to this server). If you want to carry on connecting just once, without adding the key to the store, choose 'No'. If you do not trust this host, choose 'Cancel' to abandon the connection. Choose an option (Y)es, (N)o, (C)ancel (hitting Enter cancels): Hitting YES here lets the command execute, but does NOT put the cert name in the store, I expect because it shows correctly (and is probably already present under the store with the correct case in the name) - consequently, it continuously prompts for every file with no way to "mass confirm"
×
×
  • Create New...