Jump to content

Search the Community

Showing results for tags 'config'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Plastic SCM
    • General
    • Installation and configuration
    • Unity 3D
    • Plastic SCM on Mac
    • Plastic SCM on Linux
    • Gluon
    • Git interop
    • Integrations
    • Community Edition
    • Branching and merging
    • Announcements
  • Plastic SCM 4.0 Beta (Closed)
  • Plastic Cloud
    • General
    • Configuration
  • SemanticMerge
    • General
    • License
    • SCM's configuration
    • Share your experience!
    • External Parsers
  • GitJungle
  • Method History for Subversion

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 4 results

  1. Hello, i'm trying to get PlasticSCM works on Mac as it works for PC. We need Jira integration in our production pipeline and it works well on PC. I've seen that there's no configuration window on mac to setup plastic scm link with jira. So i followed the given tutorial at https://www.plasticscm.com/documentation/extensions/plastic-scm-version-control-task-and-issue-tracking-guide#Jiraintegration By the way, there's a mistake in path of the client.conf configuration <Extensions> <Extension AssemblyFile="plasticscm_install_path/client/extensions/jira/jiraextension.dll" /> </Extensions> should be <Extensions> <Extension AssemblyFile="/Application/PlasticSCM.app/Contents/MonoBundle/extensions/jira/jiraextension.dll" /> </Extensions> my client.conf is adapted as following (just added the previous lines at the end) <?xml version="1.0"?> <ClientConfigData xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <Language>fr</Language> <WorkspaceServer>myserverurlandport</WorkspaceServer> <WorkingMode>LDAPWorkingMode</WorkingMode> <SecurityConfig>securityconfig</SecurityConfig> <CurrentWorkspace>/Users/stephane/wkspaces/SampleRepo</CurrentWorkspace> <MergeTools> <MergeToolData> <FileType>enTextFile</FileType> <FileExtensions>*</FileExtensions> <Tools> <string>/usr/local/bin/macmergetool -b="@basefile" -bn="@basesymbolic" -bh="@basehash" -s="@sourcefile" -sn="@sourcesymbolic" -sh="@sourcehash" -d="@destinationfile" -dn="@destinationsymbolic" -dh="@destinationhash" -a -r="@output" -t="@filetype" -i="@comparationmethod" -e="@fileencoding" -m="@mergetype" -re="@resultencoding" --progress="@progress" --extrainfofile="@extrainfofile"</string> </Tools> </MergeToolData> </MergeTools> <DiffTools> <DiffToolData> <FileType>enTextFile</FileType> <FileExtensions>*</FileExtensions> <Tools> <string>/usr/local/bin/macmergetool -s="@sourcefile" -sn="@sourcesymbolic" -d="@destinationfile" -dn="@destinationsymbolic" -t="@filetype" -i="@comparationmethod" -e="@fileencoding"</string> </Tools> </DiffToolData> </DiffTools> <ShowPerformanceWarnings>yes</ShowPerformanceWarnings> <MergeWithPendingChanges>no</MergeWithPendingChanges> <StackTrace>no</StackTrace> <SetFilesAsReadOnly>no</SetFilesAsReadOnly> <SetRevisionFileDate>no</SetRevisionFileDate> <SupportSmbWorkspaces>no</SupportSmbWorkspaces> <PerformAddPlusCi>no</PerformAddPlusCi> <CheckFileContentForChanged>no</CheckFileContentForChanged> <CaseSensitiveFsOnMac>no</CaseSensitiveFsOnMac> <SameItemDifferentCaseError>no</SameItemDifferentCaseError> <CheckinQueuesSize>50</CheckinQueuesSize> <DownloadPoolSize>6</DownloadPoolSize> <LastRunningEdition>team_or_enterprise</LastRunningEdition> <Extensions> <Extension AssemblyFile="/Applications/PlasticSCM.app/Contents/MonoBundle/extensions/jira/jiraextension.dll" /> </Extensions> </ClientConfigData> and my jira.conf in ~/.Plastic4/issuetrackers/sll_serverurl_port/allrepos contains a jira.conf file with the following data WorkingMode=TaskOnBranch Name=Host;Value=ourjiraurl/;Type=Host;IsGlobal=True Name=User name;Value=myjiraemail;Type=User;IsGlobal=False Name=Password;Value=myjiratoken;Type=Password;IsGlobal=False Name=Branch prefix;Value=;Type=BranchPrefix;IsGlobal=True Name=Project Key;Value=MULTIPLE_PROJECTS;Type=Text;IsGlobal=True Name=Custom Field ID;Value=;Type=Text;IsGlobal=True Name=Use LDAP credentials if available;Value=False;Type=Boolean;IsGlobal=False Name=Use default proxy credentials;Value=False;Type=Boolean;IsGlobal=False Name=Issue query limit;Value=50;Type=Text;IsGlobal=False Name=Resolved issue states;Value=Done;Type=Text;IsGlobal=False Name=Issue types;Value=;Type=Text;IsGlobal=False Name=Fields mapping;Value=;Type=Text;IsGlobal=False Name=REST URL;Value=/rest/api/2/;Type=Text;IsGlobal=True Name=Task URL;Value=/browse/;Type=Text;IsGlobal=True Name=Status transitions;Value=[DONE]-Done;Type=Text;IsGlobal=True when trying to create a branch it calls the jiraextension but i get an exception Invalid URI the format of the URI could not be determined. the log file indicates the following 2021-02-17 11:16:10,212 stephane ERROR PlasticThread - Error when performing background operation: Invalid URI: The format of the URI could not be determined. 2021-02-17 11:16:10,214 stephane DEBUG PlasticThread - Stack trace: at System.Uri.CreateThis (System.String uri, System.Boolean dontEscape, System.UriKind uriKind) [0x0007b] in <ca617bcbee124d63852388fd7f3106e6>:0 at System.Uri..ctor (System.String uriString) [0x00014] in <ca617bcbee124d63852388fd7f3106e6>:0 at Codice.Client.IssueTracker.Jira.JiraRestClient.GetBaseRestUri () [0x00060] in <8ac37d92524a463887d6e42f943350d8>:0 at Codice.Client.IssueTracker.Jira.JiraRestClient.CreateAuthenticatedRequest (System.String partialUri, System.String method) [0x00001] in <8ac37d92524a463887d6e42f943350d8>:0 at Codice.Client.IssueTracker.Jira.JiraRestClient.TryRequest (System.String partialUri, System.String httpMethod, System.Object content, System.String& response) [0x0001c] in <8ac37d92524a463887d6e42f943350d8>:0 at Codice.Client.IssueTracker.Jira.JiraRestClient.TryGet[T] (System.String partialUri, T& result) [0x00008] in <8ac37d92524a463887d6e42f943350d8>:0 at Codice.Client.IssueTracker.Jira.JiraRestClient.DoGetTasks (System.String conditions) [0x00018] in <8ac37d92524a463887d6e42f943350d8>:0 at Codice.Client.IssueTracker.Jira.JiraRestClient.GetPendingTasks (System.String assignee) [0x00014] in <8ac37d92524a463887d6e42f943350d8>:0 at Codice.Client.IssueTracker.Jira.JiraHandler.GetPendingTasks (System.String assignee) [0x00001] in <8ac37d92524a463887d6e42f943350d8>:0 at Codice.Client.IssueTracker.Jira.JiraExtension.GetPendingTasks (System.String assignee) [0x00001] in <8ac37d92524a463887d6e42f943350d8>:0 at im.b (System.Boolean A_0) [0x0000b] in <b816f616cec244e082b4ba1c3a67eb57>:0 at im+a.b () [0x00001] in <b816f616cec244e082b4ba1c3a67eb57>:0 at Codice.Client.Common.Threading.PlasticThread.ThreadWork (System.Object state) [0x0000a] in <c486789c633545be9a72ad39a565b17f>:0 I tried to use the same config jira config file as my Plastic SCM client has with the same result even if it works well on my PC. Has somebody some suggestion ? Thanks by advance St├ęphane
  2. Hi, So I had the following issue just pop up. I believe that this might have been triggered by a lack of disk space when doing a push or adding something maybe? All I know is that plastic was working for me this morning. I could push/pull and do everything. Now every time I start plastic I get that error. The actual image is attached but it's similar to the title. I have no clue where to move from here. I tried fully uninstalling Plastic and re-downloading it and I still have that issue so I'm a bit lost. Do you all know what could be up with this? Thanks in advance, Adrian
  3. How do you properly set up the launch command for the diff and merge tools in PlasticSCM on OSX? I've looked through the manual and searched the forums with no solution. I can't get PlasticSCM to launch SemanticMerge. It's probably because I don't have the diff/merge tool configured properly in PlasticSCM. I've added it as an "External diff tool" with the command: "/Applications/semanticmerge.app" -s="@sourcefile" -sn="@sourcesymbolic" -d="@destinationfile" -dn="@destinationsymbolic" -i="@comparationmethod" -e="@fileencoding" -edt=default I've also tried supplying semanticmerge.exe inside the app folder, with no luck.
  4. I just updated to the latest Mac Client, and when i restarted after install, the client is completely locked up. I tried to find any config files that had local client config in them and reset them, but the client always comes up in the same non-functional state. I've also uninstalled & reinstalled a number of times, but the client always comes up in the same bad state. I really can't work until I can apply some shelved changes to my workspace. Any suggestions? Paul
×
×
  • Create New...