Jump to content

Search the Community

Showing results for tags 'ubuntu'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Plastic SCM
    • General
    • Installation and configuration
    • Unity 3D
    • Plastic SCM on Mac
    • Plastic SCM on Linux
    • Gluon
    • Git interop
    • Integrations
    • Community Edition
    • Branching and merging
    • Announcements
  • Plastic SCM 4.0 Beta (Closed)
  • Plastic Cloud
    • General
    • Configuration
  • SemanticMerge
    • General
    • License
    • SCM's configuration
    • Share your experience!
    • External Parsers
  • GitJungle
  • Method History for Subversion

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 17 results

  1. Hello, I'm new to plasticscm and I'm trying to setup RepliKate on my ubuntu server but I'm having trouble with the command getting stuck waiting for my cloud credentials and I couldn't find how to work around this problem. Here is what I've done so far: 1. Compiled RepliKate,copied the files to /opt/plasticscm5/replikate and set proper permissions: 2.Executed RepliKate using plastic's copy of mono: 3. The command gets stuck there and if i try running the last printed line, i get the following: I'm assuming the same prompt happens during RepliKate execution but I cant find how to fix this. Any suggestions? Thanks =)
  2. Ubuntu 16.04 will not accept the plastic repos, it complains that: W: https://www.plasticscm.com/plasticrepo/plasticscm-common/Ubuntu_14.04/./Release.gpg: Signature by key FC547B45E1BB2D5BA32CFB6A9A847BB1704CBB6B uses weak digest algorithm (SHA1) W: https://www.plasticscm.com/plasticrepo/plasticscm-latest/Ubuntu_14.04/./Release.gpg: Signature by key BEA0651E0EE3CBC4CF25092A3A8583CE515E508F uses weak digest algorithm (SHA1) E: Failed to fetch No Hash entry in Release file /var/lib/apt/lists/partial/www.plasticscm.com_plasticrepo_plasticscm-common_Ubuntu%5f14.04_._Release which is considered strong enough for security purposes E: Failed to fetch No Hash entry in Release file /var/lib/apt/lists/partial/www.plasticscm.com_plasticrepo_plasticscm-latest_Ubuntu%5f14.04_._Release which is considered strong enough for security purposes E: Some index files failed to download. They have been ignored, or old ones used instead. Update: I see now I already posted about this a while ago in installation and that I should just download the client zip file. I have done that and it works. However, it would be much better if the ubuntu package could be updated to be signed with a valid key. Having an invalid installation package will most likely turn off most people evaluating plastic on linux and prevent them from considering it
  3. hi all we just purchased a team licence for our little game dev studio and the main server is running without issues on linux ubuntu 16.04 i want it to replicate automatically on the backup server (another machine under linux ubuntu 16.04) i already followed the install steps from : https://www.plasticscm.com/plastic-for-linux/ubuntu-16.html for the backup server and created a "plasticscm" user on both sides... so what s next please ? :-)
  4. I'm using a free personal license. I just installed Plastic SCM in a Ubuntu 14.04. I'm trying to create a new admin user (the only one I am allowed to create), I just added him with umtool, but I need a tool to give him admin rights. When I try to open umtoolgui via xming it show me this error: gtkplastic and the rest of the gui tools worked ok
  5. This outlines some of the issues that I had using PlasticSCM on Ubuntu 15.10 and provides the solutions I used. I had already configured PlasticSCM using the command line tools, but I wanted others to be able to use the GUI tools. The GUI tools did not work out of the box for Ubuntu 15.10 nor 15.04 Running PlasticSCM Team Server: Ubuntu 15.10 with MySQL backend Clients: Windows Issues: GUI configuration tools did not work under Ubuntu 15.10 (nor 15.04) Programs: configureserver, umtoolgui, admintool Error: "System.TypeLoadException: Could not load type 'y3' from assembly" this was somewhat of a red herring as exposed after running the programs with the following export variables set export MONO_LOG_LEVEL=debug export MONO_LOG_MASK=asm The issue was that the GAC versions that were being searched for were 4.0.0.0 but the versions provided were 2.0.0.0 Fix: add symlinks from 2.0.0.0__* to 4.0.0.0__* #!/bin/bash # -- add 4.0.0.0 symlinks cd /opt/plasticscm5/mono/lib/mono/gac for i in $(find -type d -name '2.0.0.0__*'); do b=${i/\/2.0.0.0/\/4.0.0.0}; a=${i##*/}; sudo ln -sf $a $b; done Error: all config files had an xml element that was a violation: "<runtime>" [ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: An exception was thrown by the type initializer for System.Windows.Forms.WindowsFormsSynchronizationContext ---> System.TypeInitializationException: An exception was thrown by the type initializer for System.Windows.Forms.XplatUI ---> System.TypeInitializationException: An exception was thrown by the type initializer for System.Net.Sockets.Socket ---> System.Configuration.ConfigurationErrorsException: Error Initializing the configuration system. ---> System.Configuration.ConfigurationErrorsException: Unrecognized configuration section <runtime> (/opt/plasticscm5/server/umtoolgui.exe.config line 2) Fix: comment out or remove the "<runtime>" block from admintool.exe.config, configureserver.exe.config, umtoolgui.exe.config Error: missing admintool shell script. Fix: created admintool, in the manner of umtoolgui !/bin/sh PROG=${0##*/} PLASTICSERVERDIR=`dirname \`readlink -fn $0\`` exec "$PLASTICSERVERDIR/mono_setup" $PROG mono "$PLASTICSERVERDIR/$PROG.exe" "$@" Error: admintool complains of bad theme path referencing a theme with the a path like "theme\windows". Of course unix uses forward slashes Fix: hack created a fake link to handle that bad path #!/bin/bash cd /opt/plasticscm5/ ln -sf theme/windows theme\\windows Example of my db.conf for mysql <DbConfig> <ProviderName>mysql</ProviderName> <ConnectionString>Server=127.0.0.1;User ID=root;Password=redacted;Database={0};Pooling=true</ConnectionString> <DatabasePath/> <DatabasePrefix>production_</DatabasePrefix> </DbConfig> Example of my backup script db=$(mysql -u root -predacted -h localhost -e 'show databases;' | grep production_rep) mysqldump -u root -predacted -h localhost --databases $db | gzip -c > $(date +%FT%T)-production_rep.mysqldump.gz
  6. Xorcist

    Plastic for ARM?

    I'm running Lubuntu 14.04 LTS on an ARM device (Samsung Exynos5422 Cortex-A15 Processor). Does plastic have a build for ARM? If not has anyone sucessfuly run Plastic using QEMU or ExaGear? If so, how well does it work?
  7. Hi, I followed the steps for installation from, http://www.plasticscm.com/plastic-for-linux/index.html when I run, sudo apt-get install plasticscm-client it ends with the following error, Preparing to unpack .../plasticscm-mono3-devel_3.0.3.1-1.1_all.deb ... Unpacking plasticscm-mono3-devel (3.0.3.1-1.1) ... dpkg: error processing archive /var/cache/apt/archives/plasticscm-mono3-devel_3.0.3.1-1.1_all.deb (--unpack): trying to overwrite '/usr/bin/mono-api-check', which is also in package mono-devel 3.2.8+dfsg-4ubuntu1 Selecting previously unselected package plasticscm-client. Preparing to unpack .../plasticscm-client_5.4.16.634_amd64.deb ... Unpacking plasticscm-client (5.4.16.634) ... Processing triggers for gnome-menus (3.10.1-0ubuntu2) ... Processing triggers for desktop-file-utils (0.22-1ubuntu1) ... Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ... Rebuilding /usr/share/applications/bamf-2.index... Processing triggers for mime-support (3.54ubuntu1) ... E: Sub-process /usr/bin/dpkg returned an error code (1) Any idea what is going wrong? Thanks and regards, Kanthagirish
  8. Hello, I am trying to install Plastic 5.4 on an Amazon EC2 server running Ubuntu 14. I am running into a lot of problems. My current one is when I run "sudo apt-get install plasticscm-client plasticscm-server" I get dependency errors (listed below). I am very new to this so if anyone has some beginner advice it would be very much appreciated! The following packages have unmet dependencies: plasticscm-client : Depends: plasticscm-mono3-runtime (= 3.0.3.1-1.1) but it is not installable Depends: plasticscm-libmono3-2.0-1 (= 3.0.3.1-1.1) but it is not installable Depends: plasticscm-libmono3-profiler (= 3.0.3.1-1.1) but it is not installable Depends: plasticscm-mono3-2.0-gac (= 3.0.3.1-1.1) but it is not installable Depends: plasticscm-mono3-4.0-gac (= 3.0.3.1-1.1) but it is not installable Depends: plasticscm-mono3-2.0-service (= 3.0.3.1-1.1) but it is not installable Depends: plasticscm-mono3-4.0-service (= 3.0.3.1-1.1) but it is not installable Depends: plasticscm-libmono3-cil-dev (= 3.0.3.1-1.1) but it is not installable Depends: plasticscm-mono3-utils (= 3.0.3.1-1.1) but it is not installable Depends: plasticscm-mono3-devel (= 3.0.3.1-1.1) but it is not installable Depends: plasticscm-libgdiplus (= 2.10.1-4) but it is not installable Depends: plasticscm-zlib1g (= 1:1.2.3.5) but it is not installable Depends: plasticscm-zlib1g-dev (= 1:1.2.3.5) but it is not installable
  9. Hi! I have installed Plastic server and client on my Ubuntu server from Server says its version is 5.4.14.599. My Windows client is the latest from downloads section (5.4.16.617 - confirmed via cm version). When I try to connect to the server I get Is it normal that latest WIndows distribution is different from latest Linux distribution? I guess best fix would be to downgrade my client to 5.4.14?
  10. Hello, I'm using sematicmergetool on Ubuntu 14.04 for a while, but a few weeks ago started to throw exceptions while i press the save button after solving conflicts. I've attached the log and the stdout. (Tried with examples and real project too; same result) Could you please help me solve this? Thank you, David UPD: screenshot attached semanticmerge.log.txt semanticmerge_stdout.txt
  11. Hi, I don't see the eclipse plugin for plastic scm. I figured I need to run the installer again and check the plugin installation. how do I do that ? Eclipse is 3.7.2 cm is 4.1 ubunto 12.04 Thanks, Ran
  12. hadesz

    Ubuntu 14.04 install problems

    Hello, I'm trying to install to ubuntu 14.04, but i got dependency errors, so i cant install it. # apt-get install semanticmerge Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: semanticmerge : Depends: semanticmerge-gtk-sharp but it is not going to be installed E: Unable to correct problems, you have held broken packages. I tried to install 'semanticmerge-gtk-sharp' manually: # apt-get install semanticmerge-gtk-sharp Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: semanticmerge-gtk-sharp : Depends: plasticscm-libmono3-cil-dev but it is not going to be installed Depends: plasticscm-libgdiplus but it is not going to be installed E: Unable to correct problems, you have held broken packages. And that's continues. As I see, there are some plasticscm packages, which are not released for Trusty? Thank you hadesz
  13. Hello, I am trying to install Plastic SCM v4.1 on Ubuntu 14.04 LTS. I have tried the 64bit version but understand from reading the forums that this has issues. Have tried to install the 32bit version but the .run refuses to execute. In a last Google attempt I found this page: https://www.plasticscm.com/plastic-for-linux/index.html. I thought this would solve my issues as being able to use the package manager is always preferred. After following the guide above I get the following error. The following packages have unmet dependencies. plasticscm-client : Depends: plasticscm-libmono3-cil-dev (<= 3.0.3.1-1.1) but it is not going to be installed Depends: plasticscm-mono3-devel (<= 3.0.3.1-1.1) but it is not going to be installed Depends: plasticscm-libgdiplus (<= 2.10.1-4) but it is not going to be installed E: Unable to correct problems, you have held broken packages. Does anyone know where these packages are? and why they are not located in the public repository? Thanks in advance.
  14. Hi, I'm having a problem configuring the SCM client running on Ubuntu 14 (in a VMWare virtual machine hosted on W8) and using LDAP authentication. I installed the client following the recommendation of manu in this thread http://www.plasticscm.net/index.php?/topic/2193-install-on-ubuntu-1404/. When configuring the client the follwoing message appears after clicking "Test connection". I have no clue what the problem is and how to solve this. Can you please provide help? Thanks!
  15. Hello, I've configured the tool as shown on http://www.semanticmerge.com/documentation/main.shtml#CommandLineClientConfiguration of course updated the path and others. I've run into 2 errors: There were line ending errors, and some changes in the class annotation, and the tool cannot solve it via intelligent way, and the text merge tool cannot started "no text merge tool have been specified" Some png's are missing from /opt/semanticmerge/icons/java GLib.GException: Failed to open file '/opt/semanticmerge/icons/java/namespace.png': No such file or directory at Gdk.Pixbuf..ctor (System.String filename) [0x00000] in <filename unknown>:0 at SemanticGtk.DeclarationImages.GetPixbuf (e6 declaration, Language fileLanguage) [0x00000] in <filename unknown>:0 at SemanticGtk.TreeBuilder.b (Gtk.TreeViewColumn A_0, Gtk.CellRenderer A_1, TreeModel A_2, TreeIter A_3) [0x00000] in <filename unknown>:0 at GtkSharp.TreeCellDataFuncWrapper.NativeCallback (IntPtr tree_column, IntPtr cell, IntPtr tree_model, IntPtr iter, IntPtr data) [0x00000] in <filename unknown>:0 GLib.GException: Failed to open file '/opt/semanticmerge/icons/java/namespace.png': No such file or directory at Gdk.Pixbuf..ctor (System.String filename) [0x00000] in <filename unknown>:0 at SemanticGtk.DeclarationImages.GetPixbuf (e6 declaration, Language fileLanguage) [0x00000] in <filename unknown>:0 at SemanticGtk.TreeBuilder.b (Gtk.TreeViewColumn A_0, Gtk.CellRenderer A_1, TreeModel A_2, TreeIter A_3) [0x00000] in <filename unknown>:0 at GtkSharp.TreeCellDataFuncWrapper.NativeCallback (IntPtr tree_column, IntPtr cell, IntPtr tree_model, IntPtr iter, IntPtr data) [0x00000] in <filename unknown>:0 GLib.GException: Failed to open file '/opt/semanticmerge/icons/java/namespace.png': No such file or directory at Gdk.Pixbuf..ctor (System.String filename) [0x00000] in <filename unknown>:0 at SemanticGtk.DeclarationImages.GetPixbuf (e6 declaration, Language fileLanguage) [0x00000] in <filename unknown>:0 at SemanticGtk.TreeBuilder.b (Gtk.TreeViewColumn A_0, Gtk.CellRenderer A_1, TreeModel A_2, TreeIter A_3) [0x00000] in <filename unknown>:0 at GtkSharp.TreeCellDataFuncWrapper.NativeCallback (IntPtr tree_column, IntPtr cell, IntPtr tree_model, IntPtr iter, IntPtr data) [0x00000] in <filename unknown>:0
  16. Hi All, Today I was armed with good intention to install PlasticSCM on our company server (Ubuntu 12.04 LTS). However, after I was done configuring the APT with the PlasticSCM repository I have realized that the packages platicscm-client and plasticscm-server were missing for version 5.0. I also tried 4.1 and was able to find them there. Is there a specific reason that they are missing in version 5.0?
  17. mukesh@zapty.com

    Strange GDI+ error in ubuntu 13.10

    Hi, I am using a brand new system with ubuntu 13.10 and have installed the plastic scm through normal procedure as it was described in the post http://www.plasticscm.com/plastic-for-linux/index.html using debian package. I have only installed the plasticscm-client package. The installation went on well and immediately after installation I am able to run plastic and connect to my repositories and do all operations. However when I exit plastic and restart it, I see plastic GUI loading and it tries to open some popup window and crashes with GDI+ error. If I remove .plastic4 folder and start plastic I am able to configure and continue to use plastic. But on restart I consistently get the GDI+ error. Also during initial launch if kill the plastic process instead of using the Window Close icon, then I am able to launch the plastic process w/o any error. So essentially If I avoid pressing the window close button and somehow exit the process I can relaunch the plastic and use GUI. I have attached the log generated by using MONO_LOG_LEVEL=debug to this message to give some idea of error being reported. Please help me resolve this. Thanks in advance for help. Following is the error message after briefly the plastic GUI starts to load, (detailed error log is attached) -------------------------- System.Exception: Generic Error [GDI+ status: GenericError] at System.Drawing.GDIPlus.CheckStatus (Status status) [0x00000] in <filename unknown>:0 at System.Drawing.Graphics.FillRectangle (System.Drawing.Brush brush, Int32 x, Int32 y, Int32 width, Int32 height) [0x00000] in <filename unknown>:0 at System.Drawing.Graphics.FillRectangle (System.Drawing.Brush brush, Rectangle rect) [0x00000] in <filename unknown>:0 at (wrapper remoting-invoke-with-check) System.Drawing.Graphics:FillRectangle (System.Drawing.Brush,System.Drawing.Rectangle) at System.Windows.Forms.Control.PaintControlBackground (System.Windows.Forms.PaintEventArgs pevent) [0x00000] in <filename unknown>:0 at System.Windows.Forms.Control.OnPaintBackground (System.Windows.Forms.PaintEventArgs pevent) [0x00000] in <filename unknown>:0 at System.Windows.Forms.Control.WmPaint (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0 at System.Windows.Forms.Control.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0 at System.Windows.Forms.Control+ControlWindowTarget.OnMessage (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0 at System.Windows.Forms.Control+ControlNativeWindow.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0 at System.Windows.Forms.NativeWindow.WndProc (IntPtr hWnd, Msg msg, IntPtr wParam, IntPtr lParam) [0x00000] in <filename unknown>:0 p.txt
×