Jump to content
esthrim

Suddenly all the changeset is missing ?

Recommended Posts

Hi, 

 

I already did several check-in,

but suddenly when i open the branch explorer, it shows

"No data found. The Server did not return any data for the specified date filter",  

 

in the Change-sets tab also empty.

 

when i opened the pending changes tab, and clicked the refresh button, there is no pending changes item displayed...

 

How could this happened?,  and what is the solution ??

 

FYI, I use 4.1.10.411 Gotham Version. my backend is  mysql.

 

Thanks..

Share this post


Link to post
Share on other sites

That's weird,

 

open a command line window.

 

Change the directory to your workspace path and issue the following, post us the result.

 

> cm lrep

 

> cm find branch

 

> cm find changeset

Share this post


Link to post
Share on other sites
5        0        /main                10/25/2012 2:04:54 PM immanuel SOA Root dir4398     1        /main                10/25/2012 2:11:22 PM immanuel SOA First Time Commit4423     2        /main                10/29/2012 2:04:30 PM immanuel SOA Update Report  DueDate4548     3        /main                11/22/2012 9:06:25 AM immanuel SOA Finish All Report Modify to SOA4599     4        /main                11/26/2012 2:06:26 PM immanuel SOA TabChangePassword4695     5        /main                11/27/2012 2:55:59 PM immanuel SOA Add Unchecked Ignore Warning,  Remove CIF Related Pages.4713     6        /main                12/6/2012 1:44:21 PM john     SOA Add new jsp (TabCalendarSLog) for Menu Site Log and New Image loading2.gif4880     7        /main                12/6/2012 2:00:04 PM john     SOA skin.css, ad .report .header .filter-content4891     8        /main                12/6/2012 4:11:01 PM john     SOA delete debug4924     9        /main                12/11/2012 3:12:23 PM immanuel SOA change BR tag4943     10       /main                12/27/2012 4:23:14 PM john     SOA Class bag. Controling :4968     11       /main                12/27/2012 4:36:56 PM john     SOA List Perubahan 4997     12       /main                12/27/2012 5:36:47 PM john     SOATabReport parameter r5039     13       /main                1/7/2013 2:28:20 PM immanuel SOA Add User List Export By Login Count and ActivityTotal: 14

 

 

14 Changeset found, but not in the plastic client 

Share this post


Link to post
Share on other sites

Ok,

 

in that case review the following:

 

1) Check that the branch time filter (inside Options -> Display options) is big enough to display the infomation.

2) Check the same for the changeset view.

3) Tell me if the branch view is showing something, this branch view is not having by default a time filter.

4) Did you have change something related with the server port or IP?

Share this post


Link to post
Share on other sites

Hi Manu, 

 

Sorry i didn't realize that there is time filter option,

after i change the time filter, now all the change-set has shown,

 

Thank you very much.

Share this post


Link to post
Share on other sites

Whyyyyyyyyyyyy?? Thankful for this post but oh god this feature scared the crap out of us. We thought we lost everything.  This date filter should probably not auto update itself

Share this post


Link to post
Share on other sites

sorry for the heart attack!!

We'll study if we can implement something better. Long time ago we added the following message that shows up once the brex is empty:

nodata.PNG

Referencing an invalid/too short filter, but maybe it's not enough.

Best,
Manu.

Share this post


Link to post
Share on other sites

A "select top 100 " type of filter would be a much more useful default. I'd probably never change it from that.

I operate a small custom software development company. Customers can go for months to years between changes being made to their software, so this is a very common scenario for me:  (1) open up a repository that hasn't been touched in several months  (2) go to see the history of the project -   more often than not, the changeset view is empty at this point.  I then have to make a wild guess as to what date to put in to the filter to get to see something.

Even if the repository is YEARS old, the default view of the change set should show something.  Without experimenting and thinking through, I'm not sure what the consequences would be, but certainly when you create a workspace for the first time, you can set the filter to whatever you like, and actually if a literal date is remembered now, then as time goes on with an active project, the list of change sets is going to get longer and longer yet the developers are usually only going to be interested in the top few.

 

Share this post


Link to post
Share on other sites

Case in point - I just opened Plastic GUI this morning, on the workspace I had open yesterday, but the filter settings have reset to today's date and it now only shows the one change set in the last month.

Selection_1046.png

Share this post


Link to post
Share on other sites

Thank you for the input. We'll try to improve it.

Until we do it please keep in mind how it works and the mechanisms you have to workaround it.

Share this post


Link to post
Share on other sites

This "feature" just totally confused me as well. I guess nothing was ever implemented to address it.

Share this post


Link to post
Share on other sites

Hi,

The branch explorer date filter is showing by default the data from the last month. But you can enter a custom date filter and it should be remembered the next time you open it.

What improvoment would you like?

Regards,

Carlos.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...