Jump to content

GitSync not working (with this specific repo) with BitBucket


Recommended Posts

Hi everybody!


Long time without me posting anything here!


Well, I've been trying to use GitSync and for sample repos everything is looking great!

But... In this particular repository, in older versions of 4.2 and 5.0 in the end of the "Sending" step, I always get an error message when validating...


I have made some prints for you to see the progress using the version. Everything worked as expected! No error messages!



















Buuuuuuuuuuuut... When I try to see the commit in BitBucket's website, I got this screen:






If I try to sync the uploaded repo to another brand new one repo in plastic (downloading from BitBucket), I got this error message:





This is very strange. I tried to GitSync with smaller repos and everything worked like it should.

I'm attaching here the --nodata fast-export file generated by plastic, maybe it will help! (please, change the extension to .dat. When uploading the .dat file I've got the message: You aren't permitted to upload this kind of file)




I hope you can reproduce the problem! If you wont be able to reproduce it or need any other info, just ask!


PS: In a few months ago I exchanged e-mail about this same issue with Carlos Alba, I don't know if he remembers... :)

Link to comment
Share on other sites

I just installed and I was trying to pull from GitHub, and it would report successful, but when it finished the branch explorer would be completely empty (no branches or anything) and say "No data available" (I think).  Same with the change sets.  I could use the branches view, but when I started trying to create new branches I started getting validation errors.  I've been able to push and pull to both github (I had this repo working normally prior to as well as bit bucket with no problems.  Did break something?

Link to comment
Share on other sites

Hi Gorilla!


Actually, I'm having sync problems with BitBucket with the same repo for a few months now. It's always the same problem. Even with the 4.2.x.x versions.

I never tried the github because it does not allows me to create a private repo using free account...






As I said in the previous post, I can work normally with others sample repos. The problems are with this one. =/

Link to comment
Share on other sites

HI cid, yea I knew I wasn't answering your question - sorry - it's just that your issue got me to thinking about the problem I was having earlier and made me wonder if there is something different in 5.0.  I misread your comment that it was broke in 4.2 and 5.0 as "it worked in 4.2, not in 5.0 its broke".  Again, sorry for the confusion. I've never had a problem sync'ing with bitbucket.  I have had some bitbucket repo's get corrupted though, can you do a push/pull with git itself from that repo?

Link to comment
Share on other sites

Hi Cidico,


I´ve imported the fast-export file to Plastic with no issues. Then I created a sample Bitbucket repository and synced them.  It seems that it worked fine.


This is the Bitbucket "commit" view:





Could you try to sync this repository to a Plastic clean one? Not sure why you are getting this error on Bitbucket´s side:




If you try to sync to a new clean Bitbucket repository, does the issue persist?




Link to comment
Share on other sites

Hi Carlos!


Yes, the problems persist with a clean repository, unfortunately! 

I actually deleted my account several times and recreated the repositiry.

Your import is ok, I can recognize the branches.


This is very strange!!


I've even tried to do the import in a clean machine (formated the pc, installed VS and Plastic), so it does not seems to be a environment problem. :( :( :(


PS: One thing I'm noticing is some comments on checkins are not been fully exported.

This is a sample: https://bitbucket.org/teamcarlos/cidicoimporttest/commits/52bcf8963d03707daa253f8a22ed7c15ba818e80

Even smaller comments are not been fully exported: https://bitbucket.org/teamcarlos/cidicoimporttest/commits/830134e6e48fb5b9033633eb74cee2bc80075fd7


Now I don't know what can it be!

Link to comment
Share on other sites



Could you delete the attributes created in the Plastic repository. For some reason, they could be corrupted. If you do it, and reimport to a clean Bitbucket repository, it should reproduce the same operation I did before.


Another possibility is that the no-data repository doesn´t reproduce the issue, but is a bit strange...




Link to comment
Share on other sites

If you want to, I can send you the real repository file! :)


Another strange thing:

I can reproduce the issue trying to sync the repository from office. I copied the .sqlite file and added here at work.

So, MAYBE, just MAYBE, the problem can be in my repository file or in the last chance, the repository content. :/


I'll try what you asked at home tonight!

Link to comment
Share on other sites



I'm almost giving up. :(

I deleted the repositories attributes as you asked Carlos and created a clean repository on BitBucket but the problems persist!!!

What sort of black magic are you using? :P


I don't know what else can cause the problem... :( :( :( :( :( :(

Link to comment
Share on other sites



The issue could be related to the repository file.  If you import the "fast-export" file you posted above, and then sync it with Bitbucket (same steps I did) are you able to reproduce the error?


Could you send me the real repository file? You said :"I can reproduce the issue trying to sync the repository from office". But if you use replication from Plastic branch explorer, is the issue happening too?




Link to comment
Share on other sites

Hi Carlos!


The issue is related to both. Comments on branches and checkins are empty or are being truncated.

I don't use long comments but I do use some chars that are "normal" in Brazillian Portuguese like "ç, á, ã, é, à". I think spanish also have some "not usual characters".


Just adding some more info:


I've got the repo working fine with BitBucket, BUT, after some syncs the repo was corrupted again and I've got the same error 500 page on BitBucket. :/

Link to comment
Share on other sites

Hey Carlos!


I was wonder if, maybe, just maybe, the "file corruption" (I'm adding quotes because it only corrupts the Git-side, the Plastic repository is working just fine...) problem can be related to the SQLite backend.


Is stable already to use other backend with 5.0 releases?!

I can try it tonight at home! :)

Link to comment
Share on other sites

Well, trying with others backends haven't worked at all.

It actually displayed a very strange error when running "cm fe" and trying to sync with git via UI.

I've changed my backend to SQL Server CE.


Here is the server's log file: plastic.server.txt


The syncing via GUI displayed: post-188-0-99428200-1383794125_thumb.png


The "cm fe" command error: post-188-0-87701200-1383794122_thumb.png


Weird things are happening.

Link to comment
Share on other sites

Well, I tried a whole new approach, and no good news. :(


What I did tonight:


  1. I've cleared the plastic repos on server's folder;
  2. Restored the initial SQLite repo files;
  3. After that, I was able to fast export the repo content;
  4. I've changed the database backend to SQLServer CE;
  5. Stoped plastic's service;
  6. Cleared the repos file on server's folder;
  7. Started plastic's service;
  8. Imported the fast-export file with success;
  9. After that, I was able to initially sync with BitBucket newly created repo (for testing purposes);
  10. Locally in my plastic's installation, created on branch and performed a checkin;
  11. Synced with BitBucket without any error message. Everything went fine;
  12. When trying to see the changes at BitBucket site, the checkin is not displayed at my "Overview" page and the repo website is showing the Error 500 again;

So it seems that it's not related to the backend file anymore (unless the SQLServer CE has the same issue..)!

Link to comment
Share on other sites

Ah! Almost forgot...


The "losing comments on checkins and branches" issue is not related to special chars like "á, à, é, ç...".

I just synced a new repo with a checkin comment "Check inicial" and the exported value was "Checkin inic".


Seems to be a problem when exporting the values...

Link to comment
Share on other sites

  • 1 month later...

I have the same problem with GitHub that civico posted at first post. I'm using Plastic and have a local repo with some branches, I've created a new GitHub repo with 2 files (readme and license) and want to sync it with my local repo to export all to GitHub, but at 99% it shows the error posted by civico at begining:




What's wrong?




Link to comment
Share on other sites

Hi fdbozzo!


Well, it's very, very strange.

I mean, I can work with sample repos normally!

I've been thinking that the problem can be related with my folder structures or file names..

But if you're having the same problem with only 2 simple files... I don't know what it can be anymore.. :/

Link to comment
Share on other sites

I remember that fast-export a loooooooong time ago was having trouble with BOM with UNICODE charset...

MAYBE, just MAYBE it could be related with this error.


I don't know if Manu remembers about those posts here from the 3 -> 4 migration.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...