Jump to content

Recommended Posts

Hi every body,

We currently have a big problem in our plastic system in our company (used for almost 2 years). On my PC (windows GUI) I gradually began to have some errors when clicking on "Items" or "Branch Explorer" on opened Workspaces. When this error occurs, the main panel remains blank, but i'm still able to open a tab by clicking on "Pending changes" or "Branches" for instance. The error is not present on all of my Workpaces, sometimes it's only on "Branch Explorer" , sometimes on both "Items" and "Branch Explorer",  but, day by day, new workspaces are concerned ...

The error message is "the input string format is incorrect". The error also appends when I launch plastic on a problematic repository.

Here's a screenshot (in french)

Problème plastic - Capture.JPG

I tried to delete concerned workspace and recreate a new one from the initial repository, sometimes one of the to "risky" menus ("Items" or "Branch Explorer") is fixed, sometimes not.

The problem began about 10 days ago, it is very strange and the error is not explicit at all for us, we do need plastic team help ! ;-)

Other info and mysterious facts :

- Server and all computers have been updated to 5.4.16.779, but that did not solve the problem.

- All other computer in our company are MACs, the problem is not present on Mac.

- This morning I closed all but one workspace ... bad idea, my plastic prompts the error while it starts, and now, nothing happends anymore when I click on "Workspaces" or "Repositories", nothing, no error, the main panel remains blank ... so I can't open new workspaces, we'are totally stuck !

I am ready to bring all needed info to solve the problem, but please understand that it's really urgent for us. We use plastic in all of our project, and our company loses a lot of time when the processes are broken.

Thanks a lot for your help.

 

Link to post
Share on other sites

Hi Sam,

this could be an error in a GUI-related configuration file with corrupt (or inconsisten) content. This could happen, for example, if the configuration file has been edited by hand. Keeping in mind that there are quite a lot of configuration files (branch explorer configuration, issue trackers configuration, workspaces...), so, in my opinion, the easiest -and quickest- way to check if a corrupt file is the cause of your issue is following these steps.

First of all, make sure that you don't have any pending changes on any of your workspaces: you can do so using the cli, you can find the full documentation here https://www.plasticscm.com/documentation/cli/plastic-scm-version-control-cli-guide.shtml. Plus, you can do with the command client almost anything you can do with the GUI, if at any time it is not available. Look for the "cm add" and "cm ci" commands.

Let's start:

  1. Go to your personal Plastic SCM client preferences folder, where the configuration files are stored. It should be, for Windows, %HOMEPATH%\AppData\Local\plastic4 (usually C:\Users\<your_user>\AppData\Local\plastic4)
  2. Do a full backup of the plastic4 directory contents to other directory (your Desktop, for example).
  3. Delete all of the plastic4 directory contents.
  4. Open the Plastic SCM GUI. It will prompt you to the server configuration window. Just enter your server address, click connect, and then enter your credentials (if any).
  5. Then, you'll be prompted to the welcome window. Click the tab "Join an existing project", choose the repository you usually work with, and for the workspace path on disk, just choose an existing one. This way, the client will not need to download anything from the server.
  6. Add the rest of the workspaces you had from "Workspaces > Create new workspace", choosing the path of the already existing workspace. For every workspace, go to the Items view and click "Update workspace".

Check if the "blank page" behavior you were facing before occurs again (it should not; all of the configuration files we're using are new!) If it does happen, I'd need to take a look at your Plastic SCM client logs. You can configure the plastic.exe logging following this guide https://www.plasticscm.com/documentation/technical-articles/kb-enabling-logging-for-plastic-scm-part-i.html.

If you had any issue tracker configured, you should configure it again too.

Link to post
Share on other sites

Thank you S_Luis,

I'm testing the solution ... not very easy cause I have about 100-150 opened workspaces (1.6To), and I have to keep my machine in "production state" most of the time.

I keep you in touch.

 

Link to post
Share on other sites
  • 3 weeks later...

Hi Sam,

I think we can try a different approach, Sergio's one is too much aggressive.

Let's do the following, just backup and then remove the following files:

* branchexplorer.cfg

* guivisualstate.xml

* mainform.conf

* guiclient.conf

* history2D.conf

* versiontree.conf

* branchexplorerusercolors.conf

* plasticgui.conf

You wont loose any of your workspaces, the GUI just start from fresh configuration.

If it works please close the GUI and start restoring file by file in order to identify the one causing the issue. If you find the guilty please send it to us we'll try to find out the parameter causing the failure.

Thanks!

Link to post
Share on other sites

Hi Manu,

It Worked !

The guilty is "branchexplorer.cfg" . Just for information, I have no " branchexplorerusercolors.conf " file in my plastic folder.

Howether I made a mistake when I tried to restore the files one by one, I dragged branchexplorer.cfg from my saved folder and dropped it back to plastic, I opend plastic and the bug reappeared . I deleted a new time brachexplorer.cfg from plastic directory and the bug disappeared. But ... as I dragged/dropped the file on the same disk it moved it from my save folder, not copied it to plastic... so I lost the guilty file cause I had no save of my save ... Sorry.

The good thing is that everything seems to work.

Thanks a lot !

 

Link to post
Share on other sites

Ops! Ok, no problem! if it happens again please send me a copy of the " branchexplorer.cfg" file.

My guess is there's a date written in a format that can't be later read. Maybe playing a little bit with the date filter you can make it fail again.

Keep me posted!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...