Jump to content

Upgrade from 4.1 to 5.0 issue Linux server


Recommended Posts

I am trying to upgrade Plastic from version 4.1 to 5.


I am running a single central Plastic Server on a Linux machine, with a number of remote clients on Windows machines.  The Server database is currently SQLite.


I ran the full installer for Linux - PlasticSCM- on my Linux machine.  


It seemed to run OK, not reporting any errors. Viewing the files in the server directory, they appear to be updated. With the files plasticd, umtool etc having a date stamp on them of the installation time.


Running "cm version" returns, but I assume this is the client version.  I am not sure how to check the server version.


After the install on the server, I ran my Plastic Windows client version 4.1.  The client ran fine, I was able to connect to the server check files in, retrieve repository information etc.  This was unexpected.


I then ran the Windows upgrade "PlasticSCM-" on the client machine.


The install worked fine, however when I tried to connect the server I get the following message: 


"The client version ( doesn't match the server version ("


Although the server upgrade seemed to work, it appears that it hasn't.  I have tried stopping and starting the service a couple of times.


Any help would be great.  Server is running on - redhat CentOS release 5.7.


Link to comment
Share on other sites



You can check the server version by running the admintool (mono admintool.exe) or starting the server in console mode:

mono plasticd.exe --console
plastid --console

Verify you don't have two Plastic SCM servers running.


I'll be happy to help so keep us updated.

Link to comment
Share on other sites

I used the ps tool to find what processes were running and found that there was only one instance of the server running, however that process had been running since last year, hence had not restarted after the upgrade.


After stopping the server and restarting it, this resolved my issue, using plasticsd stop and plasticsd start.


Yesterday I was only stopping and starting the service, using plasticd --stopservice and plasticd --startservice


I am a little confused as to what the difference is between the server and the service, is there an article you can point me too that may clear this up for me.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...