Jump to content
Sign in to follow this  
gonzzza

"replicate" one server to "another"

Recommended Posts

Hi! I am quite new to PlasticSCM so I'm asking your help with this probably easy task.

I have two servers, both currently have Enterprice 30 days trial license:

server1: Windows 7, PlasticSCM version 5.4.16.619 server, with PostgreSQL database backend
server2: Windows 7, PlasticSCM version 7.0.16.2937 server, with Jet database backend

I want to “replicate” completely all repositories from server1 to server2, so I can make changes to second server repositories and not worrying about breaking the first one.

Some repositories have XLink to others within same server.

Currently I have created workspaces on server2 client for each server1 repo, but I want to have ALL repositories on server2 aswell. Can you please point me where to look. Thanks a lot!  

Share this post


Link to post
Share on other sites

Hi!

 

All you have to do is to create a sync view with all the repos on one server and the other, and launch the replicas. Then you'll replicate all repos from A to B.

 

Check this for more info: https://www.plasticscm.com/documentation/gui/plastic-scm-version-control-gui-guide#Chapter23:TheSynchronizationview

 

If I wasn't clear enough, please ask! 🙂

Share this post


Link to post
Share on other sites

Thankyou! The sync view - that's what i was looking for. The problem is that sync always fails with the same error. 

Unable to write data to the transport connection: An existing connection was forcibly closed by remote host; xxx.xx.xxx.xxx:8087. An existing connection was forcibly closed by the remote host".

And the funny thing that when I try to sync from one repo - it says that connection was closed by other side. I try to replicate one server to another over VPN. Can this be a reason of disconnect?

 

Screen Shot 2019-02-04 at 22.50.47.png

Share this post


Link to post
Share on other sites

Could you attach the "plastic.debug.log.txt" file? This error could be network related. Is it failing always at the same point? 

If you are trying to migrate the repos, you can also follow a different approach: migrate your repos to Jet and just copy the databases to the new server.

Regards,

Carlos.

Share this post


Link to post
Share on other sites

Hi, If you reach us at support@codicesoftware.com we can arrange a meeting to review your setup. The problem may be network related (not sure if it always fail at the same point).

Also, If you are trying to migrate the repos, you can also follow a different approach: migrate your repos to Jet and just copy the databases to the new server.

Regards,

Carlos.

Share this post


Link to post
Share on other sites

Thank you for the answer. I think the problem is network related because after trying several times on the next day - I was able to pass this point. Unfortunately I got next error. I think I'm starting to give up. Fast-export not working, sync not working, basically nothing works...

 

Screen Shot 2019-02-10 at 00.26.50.png

Share this post


Link to post
Share on other sites

Well maybe I have to tell what I'm trying to achieve. We have a PlasticSCM server (version 5.4.16.619) with lots of ASP and DOT.NET repositories. And we want to migrate the source code to BitBucket but continue to use PlasticSCM as client from developer workstations. 

I have started to move repos one by one using fast-export and GIT fast-import. This worked fine until I tried to move repo which had XLinks to other repositories. I tried to add these repos to gitsync.conf but no luck. Can the problem be that my PlasticSCM has spaces in it's names?

Then I have tried to use Replication > Sync To Git from gui. This also fails. And seems like the problem is still in XLinks. I always get a strange EOF error. (The error message is attached as image to this post)

My last attempt was to create complete PlasticSCM server's copy, but this time version 7, so I don't harm original server and can remove all xLinks, rename repos etc. But unfortunately i cannot do this either. And then I decided to start this thread. 

Maybe there is an easier way? Can I use GitServer somehow and just replicate everything at once to another GIT server?

Screen Shot 2019-02-10 at 22.05.14 copy.png

Share this post


Link to post
Share on other sites

You can try to enable gitserver and check if this way you can workaround the problem.

For the replica error you reported, it seems to be a database problem (the guid ... for the object was not found). Why don't you just upgrade your original Palstic server to the last 8.0 version and try to migrate to git from this new version (it includes improvements in gitsync and gitserver). We can follow the different approaches to migrate to git, but I would do it from the last Plastic version.

Also, what is your company name and registered account at www.plasticsc.com?

Regards,

Carlos.

Share this post


Link to post
Share on other sites

calbzam, upgrade is the first thing i have tried - unfortunately it also failed. I had to upgrade Postgre backend to Jet but upgrade failed with some missing column error... (i don't have the exact message atm)

i can ask for the license details from the company that has hired me if this can help anyhow. But I really lost hope - EVERYTHING i've tried did not work properly.

Share this post


Link to post
Share on other sites

Could you open a ticket at support@codicesoftware.com? We can arrange a meeting with you. I would like to know more details of this Plastic version upgrade error. We should test with the last version if you plan to run Gitsync.

Also not sure if you tried GitServer. We can also enable it after the server version upgrade.

Regards,

Carlos.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...