Jump to content
Sign in to follow this  
holikri

Cannot retrieve license information

Recommended Posts

Today i got the following error in the Plastic SCM gui
"Cannot retrieve license information from the plastic SCM server. Retrying "counter" Try again now button"

I tryed to make download speed run faster(uber slow downlaoding speed like 1mb/s and i need to download 50GB) with this methon then i got the mentioned error:
"

Find your client.conf file – usually in C:\Users\username\AppData\Local\plastic4. Open it, scroll down to

<DownloadPoolSize>1</DownloadPoolSize>

and change it to

<DownloadPoolSize>16</DownloadPoolSize>

"

So now i can't do anything, always got this error

Share this post


Link to post
Share on other sites

Hi holikri,

we will take the case to our support team to evaluate it and give you a response asap

We are sorry for the inconvenience.

Thank you!

Francisco

  • Like 1

Share this post


Link to post
Share on other sites

Hi, this setting to increase the download pool size shouldn't be related to the error.

This error message ("Cannot retrieve license information from the plastic SCM server.") appears when the client can't reach the server at the moment you open the GUI.

Please drive to your Preferences panel and check if the "Check Connection" is working (also review that your credentials are correct).

And if you are using Plastic Cloud edition, drive to the Windows services panel, and start the Plastic Server 6 service. This is a local server to host your local repos and it may be down.

Regards,

Carlos.

Share this post


Link to post
Share on other sites

Alright, thank you, let me check these, anyway the downloading speed up setting did not worked for me, it's still downloaded with around 1mb/s than i'm canceled the downloading and next time i got the mentioned error

Share this post


Link to post
Share on other sites

Plastic Server 6 service was not started even it was setted to automatic, i started than everything working again but the download speed still very low

Share this post


Link to post
Share on other sites

Ok, so the internet is fast but when trying to download some data from the cloud (update operation), is it very slow? Where is your cloud data center located and where are you located?

Could you run the following speed test for your data center location? http://www.azurespeed.com/Azure/Download

You can also directly  reach us at support@codicesoftware.com

Regards,

Carlos.

 

Share this post


Link to post
Share on other sites

I ran into this problem after updating the plastic client through its built-in update feature that downloads the client installer only.

For some reason that installer seems to have also decided to uninstall the server component without asking.

After manually downloading and running the full installer (incl. server component) the server is back up again with no config lost and the license problem is also solved.

I strongly suggest that you change the client installer to not remove the server component without asking. Ideally the update feature inside the client should download the appropriate installer, client or full, depending on what's already installed on the system.

Thank you.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...