Jump to content
Marc S

How to configure upload for 1MB bandwith.

Recommended Posts

Hi.

As the title says, I have a 1MB upload bandwith. This seems to be an issue because when trying to upload too much data I get some error message telling me I lost connection after around 15mins.

Is there any ways I can set things up so it would work? 

Note that I know my connecton is stable and that I'm able to send big files on other services like Github or wetransfer.

Thanks.

Share this post


Link to post
Share on other sites

Hi,

- Are you trying to upload data to a cloud repo, right? Could you attach your client log to evaluate the errors? This way, we can confirm if it's a network issue or not. The datacenter location is key in terms of performance.

- A possibility is to perform a local commit (not directly to the cloud but to a local repository) and then push the branch to the cloud repository. This way you will need to connect to the network for pushing your changes but not for performing a checkin.

- There is a setting that may be also useful in your case:

Quote

 

Checkin compression

The compression is performed not only to save space in the Plastic SCM repositories but also to speed up network communications. You can parallel this step by editing the 'client.conf' UploadCompressionSize variable.

Don't set it to a number larger than 10; we have tested it and higher values don't get any benefits. Its default value is 1.

[client.conf]
<UploadCompressionSize>5</UploadCompressionSize>
[/client.conf]

 

 

 

 

Regards,

Carlos.

 

 

Share this post


Link to post
Share on other sites
11 minutes ago, calbzam said:

Hi,

- Are you trying to upload data to a cloud repo, right? Could you attach your client log to evaluate the errors? This way, we can confirm if it's a network issue or not. The datacenter location is key in terms of performance.

- A possibility is to perform a local commit (not directly to the cloud but to a local repository) and then push the branch to the cloud repository. This way you will need to connect to the network for pushing your changes but not for performing a checkin.

- There is a setting that may be also useful in your case:

 

Regards,

Carlos.

 

 

Hi and thanks for your help.

Yes I'm uploading to a cloud repo. Can you tell me how to get you the log? I'll reproduce the issue and send that to you. I'm located near Paris and the datacenter I chose is in Netherland so I don't think that's the problem.

I've seen I can make a local commit. I'll try to see if it works with it. That said, it would be inconvenient because I would need to be carefull not to forget sending my data to the cloud.

I just tested the compression setting. According to the progress bar, I still have the same amount of data to send but it might go faster. I'll test it with some big files.

Share this post


Link to post
Share on other sites

- Even using Netherlands, the checkin should work. Please update the thread when you perform your last tests.

- The client logs can be found at:

C:\Users\carlos\AppData\Local\plastic4\logs\plastic.debug.log.txt

Share this post


Link to post
Share on other sites

I just sent you the logs by email at support@codicesoftware.com . request (#17510)

I'm currently uploading some data on an other repo (architecture) and had a failure less than one hour ago (around 15h25). I had the error message "an existing connection must have been close by distant host".

I hope that helps.

Thanks.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...