Jump to content
Mikael Asplund

Do I need java to run SemanticMerge?

Recommended Posts

Do I seriously need to buy a java license to use this tool, or is there a way to disable java support and get it running without java installed? I have no java, or java based languages in my environment or code, but it's asking me to install java as soon as I try to run a git merge. Oddly, this seems to have very little mention in any help, etc. I can't seem to find anything when googling. 😞

Semanticmerge isn't written in java, is it? 😱

Share this post


Link to post
Share on other sites

Hi,

Semantic Merges needs java for java and C++ parser. Is this your case?

If you run one of the C# samples included with the tool, you shouldn't need to install java. Could you try it?

Regards,

Carlos.

Share this post


Link to post
Share on other sites

My case is C++... It seemed unlikely that I would need Java for that, but you're saying I do? That's unfortunate... Seemed like a really useful tool, but I've managed without it before, so I guess I can manage going forward too. :-) Thank you for your answer!

Share this post


Link to post
Share on other sites

Hi again,

The C++ parser is very complex and it uses some Eclipse libraries. That's the reason why you need java installed. There is still a free java version, right? Open jdk.

I mean why you discard Semantic Merge just because you need to install java for the C++ parser?

Regards,

Carlos.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...