Jump to content
jwvanderbeck

Plastic GUI constantly loses connection to Jira cloud

Recommended Posts

Every single time I go to create a new task branch, none of my Jira tasks will show up in the dialog.  To fix it I have to go into preferences, go to Issue Trackers, click Test Connection, close the preferences, and then go create my task branch and now the Jira tasks will show up.

Every single time I create a task branch I have to "refresh" the connection this way and it is extremely annoying.  Am I missing something?

Share this post


Link to post
Share on other sites

HI,

Could you attach the Plastic client log? This way, we should get more information fo the problem.

Regards,

Carlos.

Share this post


Link to post
Share on other sites

Hi, I can see the following error message in the logs:

Could you attach (or reach us to support@codicesoftware.com) your "C:\Users\xxx\AppData\Local\plastic4\issuetrackers" folder?

It seems to be some errors in the API calls so my guess is that some configuration could be wrong.

2019-10-20 19:27:17,707 DESKTOP-B4HHFFL\jwvan DEBUG jiraextension - Logging changeset 16 with 1 items in plain text
2019-10-20 19:27:17,775 DESKTOP-B4HHFFL\jwvan ERROR jiraextensionrest - There was a problem performing GET https://outermarkergames.atlassian.net/rest/api/2/mypreferences?key=plastic.diffchangeset.url: The remote server returned an error: (404) Not Found.
2019-10-20 19:27:17,775 DESKTOP-B4HHFFL\jwvan DEBUG jiraextensionrest - StackTrace:
   at System.Net.HttpWebRequest.GetResponse()
   at Codice.Client.IssueTracker.Jira.JiraRestClient.TryRequest(String partialUri, String httpMethod, Object content, String& response)
2019-10-20 19:27:17,775 DESKTOP-B4HHFFL\jwvan ERROR jiraextensionrest - Response from the server: {"errorMessages":["key not found: 'plastic.diffchangeset.url'"],"errors":{}}
2019-10-20 19:27:17,837 DESKTOP-B4HHFFL\jwvan ERROR jiraextensionrest - There was a problem performing GET https://outermarkergames.atlassian.net/rest/api/2/mypreferences?key=plastic.formatdata: The remote server returned an error: (404) Not Found.
2019-10-20 19:27:17,838 DESKTOP-B4HHFFL\jwvan DEBUG jiraextensionrest - StackTrace:
   at System.Net.HttpWebRequest.GetResponse()
   at Codice.Client.IssueTracker.Jira.JiraRestClient.TryRequest(String partialUri, String httpMethod, Object content, String& response)
2019-10-20 19:27:17,838 DESKTOP-B4HHFFL\jwvan ERROR jiraextensionrest - Response from the server: {"errorMessages":["key not found: 'plastic.formatdata'"],"errors":{}}
2019-10-20 19:27:17,838 DESKTOP-B4HHFFL\jwvan DEBUG jiraextension - Updating values for issue 'GT-11'
2019-10-20 19:27:17,935 DESKTOP-B4HHFFL\jwvan ERROR jiraextensionrest - There was a problem performing PUT https://outermarkergames.atlassian.net/rest/api/2/issue/GT-11: The remote server returned an error: (400) Bad Request.
2019-10-20 19:27:17,936 DESKTOP-B4HHFFL\jwvan DEBUG jiraextensionrest - StackTrace:
   at System.Net.HttpWebRequest.GetResponse()
   at Codice.Client.IssueTracker.Jira.JiraRestClient.TryRequest(String partialUri, String httpMethod, Object content, String& response)
2019-10-20 19:27:17,936 DESKTOP-B4HHFFL\jwvan ERROR jiraextensionrest - Response from the server: {"errorMessages":[],"errors":{"customfield_10000":"Field 'customfield_10000' cannot be set. It is not on the appropriate screen, or unknown."}}
2019-10-20 19:27:17,936 DESKTOP-B4HHFFL\jwvan DEBUG jiraextensionrest - Assuming 400 as Unauthorized.

Regards,

Carlos.

Share this post


Link to post
Share on other sites
4 hours ago, calbzam said:

Hi, I can see the following error message in the logs:

Could you attach (or reach us to support@codicesoftware.com) your "C:\Users\xxx\AppData\Local\plastic4\issuetrackers" folder?

It seems to be some errors in the API calls so my guess is that some configuration could be wrong.


2019-10-20 19:27:17,707 DESKTOP-B4HHFFL\jwvan DEBUG jiraextension - Logging changeset 16 with 1 items in plain text
2019-10-20 19:27:17,775 DESKTOP-B4HHFFL\jwvan ERROR jiraextensionrest - There was a problem performing GET https://outermarkergames.atlassian.net/rest/api/2/mypreferences?key=plastic.diffchangeset.url: The remote server returned an error: (404) Not Found.
2019-10-20 19:27:17,775 DESKTOP-B4HHFFL\jwvan DEBUG jiraextensionrest - StackTrace:
   at System.Net.HttpWebRequest.GetResponse()
   at Codice.Client.IssueTracker.Jira.JiraRestClient.TryRequest(String partialUri, String httpMethod, Object content, String& response)
2019-10-20 19:27:17,775 DESKTOP-B4HHFFL\jwvan ERROR jiraextensionrest - Response from the server: {"errorMessages":["key not found: 'plastic.diffchangeset.url'"],"errors":{}}
2019-10-20 19:27:17,837 DESKTOP-B4HHFFL\jwvan ERROR jiraextensionrest - There was a problem performing GET https://outermarkergames.atlassian.net/rest/api/2/mypreferences?key=plastic.formatdata: The remote server returned an error: (404) Not Found.
2019-10-20 19:27:17,838 DESKTOP-B4HHFFL\jwvan DEBUG jiraextensionrest - StackTrace:
   at System.Net.HttpWebRequest.GetResponse()
   at Codice.Client.IssueTracker.Jira.JiraRestClient.TryRequest(String partialUri, String httpMethod, Object content, String& response)
2019-10-20 19:27:17,838 DESKTOP-B4HHFFL\jwvan ERROR jiraextensionrest - Response from the server: {"errorMessages":["key not found: 'plastic.formatdata'"],"errors":{}}
2019-10-20 19:27:17,838 DESKTOP-B4HHFFL\jwvan DEBUG jiraextension - Updating values for issue 'GT-11'
2019-10-20 19:27:17,935 DESKTOP-B4HHFFL\jwvan ERROR jiraextensionrest - There was a problem performing PUT https://outermarkergames.atlassian.net/rest/api/2/issue/GT-11: The remote server returned an error: (400) Bad Request.
2019-10-20 19:27:17,936 DESKTOP-B4HHFFL\jwvan DEBUG jiraextensionrest - StackTrace:
   at System.Net.HttpWebRequest.GetResponse()
   at Codice.Client.IssueTracker.Jira.JiraRestClient.TryRequest(String partialUri, String httpMethod, Object content, String& response)
2019-10-20 19:27:17,936 DESKTOP-B4HHFFL\jwvan ERROR jiraextensionrest - Response from the server: {"errorMessages":[],"errors":{"customfield_10000":"Field 'customfield_10000' cannot be set. It is not on the appropriate screen, or unknown."}}
2019-10-20 19:27:17,936 DESKTOP-B4HHFFL\jwvan DEBUG jiraextensionrest - Assuming 400 as Unauthorized.

Regards,

Carlos.

I can get that to you in about 8 hours.  I left most of the settings as default, only setting the server address and user information.  Seems odd that it works after I first start the client, and then again after "refreshing" the connection with the Test button, but then stops in between.

Share this post


Link to post
Share on other sites

We are currently handling this issue via support ticket. We will also update this thread as soon as we have all the infomation.

Regards,

Carlos.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...