Jump to content

Install on Ubuntu 14.04


Recommended Posts



I am trying to install Plastic SCM v4.1 on Ubuntu 14.04 LTS.


I have tried the 64bit version but understand from reading the forums that this has issues. Have tried to install the 32bit version but the .run refuses to execute.


In a last Google attempt I found this page: https://www.plasticscm.com/plastic-for-linux/index.html. I thought this would solve my issues as being able to use the package manager is always preferred.


After following the guide above I get the following error.


The following packages have unmet dependencies.
 plasticscm-client : Depends: plasticscm-libmono3-cil-dev (<= but it is not going to be installed
                     Depends: plasticscm-mono3-devel (<= but it is not going to be installed
                     Depends: plasticscm-libgdiplus (<= 2.10.1-4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.



Does anyone know where these packages are? and why they are not located in the public repository?


Thanks in advance.

Link to comment
Share on other sites

The installer for 64bit, appears to install fine but this message appears in the terminal.


(main.tcl:4793): GLib-GObject-WARNING **: value "1.003413" of type 'gdouble' is invalid or out of range for property 'fraction' of type 'gdouble'


When trying to open Plastic after installation there is a error message about exceptions being thrown. This stops the program from opening.

Link to comment
Share on other sites



I wouldn't use the regular installer, it's packaging a very old mono version. You can try with the current packages for Ubuntu: https://www.plasticscm.com/plastic-for-linux/index.html


If is doesn't work for Ubuntu 14 you can always grab the latest mono (sudo apt-get install mono-runtime sudo apt-get install mono-complete) and use the zip installers: 

Link to comment
Share on other sites

  • 3 weeks later...

I've tried the installer + mono complete on Ubuntu 14.04 and I've found that's not enough to get going.  How does plasticscm reference the newer version of mono?  I've search the new version's directory structure and cannot locate a directory structure that similar to plastic's mono installation. 


I've looked at /opt/plasticscm5/config/mono_setup_env and it appears that plastic will use it's installed version of mono instead of the new version, so I changed the directory path.  I also tried to point mono_setup to /usr/bin/ but still doesn't work.  I've managed to be able to start the server configuration, and the client configuration although I had to have elevated permission to do so.  Still I get "z plastic client cannot continue and will be closed."  I'm at a loss.  Cannot get the client started.  


Any help would be greatly appreciated.

Link to comment
Share on other sites

Hi all,


we are going to schedule an internal task to support the Ubuntu 14 distro, it's currently not working.


The zlib is not fine, and the tiff library neither. We'll keep this thread update with the new actions.


Sorry for the inconveniences.


@krushin you are missing the "sudo apt.get update" command, but as I wrote you will find more libraries issues further.

Link to comment
Share on other sites



it performs! I previously had issues due to broken dependencies with "mono". I had to "apt-get purge mono-complete" and then reinstall plasticscm-client. Now it works and the issues are solved. Thanks a lot, thumbs up!




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...