Jump to content
khan-amil

JenkinsPlug : "Root element is missing"

Recommended Posts

I'm trying to setup a Mergebot with a CI plan in Jenkins, but I can't manage to make it work.

I get the following error in our logs

2020-02-04 11:21:06,049 INFO  jenkinsplug - Launch plan was requested. Fields:
2020-02-04 11:21:06,049 INFO  jenkinsplug -     PlanName: Test2
2020-02-04 11:21:06,049 INFO  jenkinsplug -     ObjectSpec: sh:91@Shooter@plastic.mds.com:8087
2020-02-04 11:21:06,049 INFO  jenkinsplug -     Comment: MergeBot - Building branch /main/Update MagicSound
2020-02-04 11:21:06,049 INFO  jenkinsplug -     Properties:
2020-02-04 11:21:06,049 INFO  jenkinsplug -             branch.head.changeset.author: EmerickAussignac
2020-02-04 11:21:06,049 INFO  jenkinsplug -             branch.head.changeset.guid: aaf53e25-37ba-4238-b344-0acd9aecd110
2020-02-04 11:21:06,049 INFO  jenkinsplug -             branch.head.changeset.number: 2776
2020-02-04 11:21:06,049 INFO  jenkinsplug -             branch.name: /main/Update MagicSound
2020-02-04 11:21:06,049 INFO  jenkinsplug -             build.name:
2020-02-04 11:21:06,049 INFO  jenkinsplug -             build.number:
2020-02-04 11:21:06,049 INFO  jenkinsplug -             label:
2020-02-04 11:21:06,049 INFO  jenkinsplug -             release.notes:
2020-02-04 11:21:06,049 INFO  jenkinsplug -             repspec: Shooter@plastic.mds.com:8087
2020-02-04 11:21:06,049 INFO  jenkinsplug -             stage: pre
2020-02-04 11:21:06,049 INFO  jenkinsplug -             task.number: Update MagicSound
2020-02-04 11:21:06,049 INFO  jenkinsplug -             trunk.head.changeset.guid: b1e2ed04-55f6-419b-909c-3d6be48b45d2
2020-02-04 11:21:06,049 INFO  jenkinsplug -             trunk.head.changeset.number: 2812
2020-02-04 11:21:06,078 ERROR jenkinsplug - Error processing message launchplan:
Message:{
  "requestId": "12254358-4d91-4fc3-8cd2-9ea1aa35f380",
  "action": "launchPlan",
  "planName": "Test2",
  "objectSpec": "sh:91@Shooter@plastic.mds.com:8087",
  "comment": "MergeBot - Building branch /main/Update MagicSound",
  "properties": {
    "branch.head.changeset.author": "EmerickAussignac",
    "branch.head.changeset.guid": "aaf53e25-37ba-4238-b344-0acd9aecd110",
    "branch.head.changeset.number": "2776",
    "branch.name": "/main/Update MagicSound",
    "build.name": null,
    "build.number": null,
    "label": "",
    "release.notes": null,
    "repspec": "Shooter@plastic.mds.com:8087",
    "stage": "pre",
    "task.number": "Update MagicSound",
 "trunk.head.changeset.guid": "b1e2ed04-55f6-419b-909c-3d6be48b45d2",
    "trunk.head.changeset.number": "2812"
  }
}. Error: Root element is missing.
2020-02-04 11:21:06,078 ERROR jenkinsplug - Root element is missing.

 

I can't see what's wrong with my setup.

Share this post


Link to post
Share on other sites

Could you attach your jenkins plug configuration? You can also reach us at support@codicesoftware.com.

Regards,

Carlos.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...