Jump to content
tyler

Bamboo sync to changeset gets latest instead

Recommended Posts

I'm seeing an issue where when I try and build a specific changeset in bamboo it syncs to the latest changeset instead. This used to work, but I'm guessing it broke sometime after a plastic server update. Is there an updated version of the plugin I can use? Or a fix/workaround? Thanks!

plugin: bamboo-plasticscm-plugin-5.14.1
server: 8.0.16.3816
bamboo: version 6.7.1 build 60705

Share this post


Link to post
Share on other sites

The Plastic server version should be relevant. Only the plugin version, Bamboo version, and the Plastic client version. Have you recently upgraded any of them?

What is your current Plastic client version installed in the Bamboo machine?

Could you attach an screenshot of the Bamboo configuration panel: Plastic SCM selector... to review it?

Regards,

Carlos.

 

Share this post


Link to post
Share on other sites

The plastic client for all of the build agents is: 8.0.16.3189
The bamboo machine is not a build agent but has plastic client installed: 7.0.16.2688

"Plastic SCM plugin - 5.14.1
Vendor: Codice Software"

image.thumb.png.c86b8a94568aecdca2710258e83be83e.png

Share this post


Link to post
Share on other sites

Hi,

- I was refering to the the build panel when you set a specific changeset instead of a branch to build.

-  Did you perform any Bamboo, Plastic recent upgrade? We haven't released a new plugin plugin version for a long time. Anyway, we will give it a try.

Regards,

Carlos.

Share this post


Link to post
Share on other sites

Bamboo and the plastic plugin have not been upgraded. Plastic server and clients build agents have both been updated.

There's a relevant conflict evident in the build logs and summary. Note the metadata is correct, but then the build summary lists the wrong custom revision.

Bamboo build metadata:
customRevision    22530
dependenciesDisabled    true
ManualBuildTriggerReason.customRevision    22530


Build summary:
Custom variables
    Custom revision 22538

Log:
simple    02-Mar-2020 15:23:43    Starting task 'Checkout Default Repository' of type 'com.atlassian.bamboo.plugins.vcs:task.vcs.checkout'
simple    02-Mar-2020 15:23:43    Checking out into C:\bamboo-agent-home\xml-data\build-dir\FIR-PKG-JOB1
simple    02-Mar-2020 15:23:43    Updating source code to revision: 22538
simple    02-Mar-2020 15:24:01    Updated source code to revision: 22538
simple    02-Mar-2020 15:24:01    Finished task 'Checkout Default Repository' with result: Success

 

Also taken from earlier in the log is all the variables:
    bamboo_repository_revision_number=22538
    bamboo_repository_32771_revision_number=22538
    bamboo_repository_32771_previous_revision_number=22538
    bamboo_planRepository_revision=22538
    bamboo_repository_previous_revision_number=22538
    bamboo_planRepository_previousRevision=22538
    bamboo_planRepository_1_revision=22538
    bamboo_repository_32771_name=Firestorm
    bamboo_planRepository_1_previousRevision=22538
    bamboo_planRepository_branchDisplayName=/main
    bamboo_planRepository_1_type=plasticscm
    bamboo_customRevision=22530

 

 

From all of this it looks like a bamboo bug, but I'm 99% sure this used to work and bamboo hasn't been updated while plastic has.

Share this post


Link to post
Share on other sites

Hi Tyler,

 

We have been going through the issue, but we were not able to reproduce it yet.

We are still trying some scenarios, but anything you could tell us about your setup would help.

 

Best,

Héber.

Share this post


Link to post
Share on other sites

The only thing I can think of is we have 3 build agents and commonly we're doing custom builds for a past revision.

Here's a case I just tried:
- Latest cs is 23277 and Agent 1 is currently building it
- Agent 2 last built 23275
- I Run Customized with 23275 as the revision
- Agent 2 starts the build and updates to 23277, even listing 23277 as the custom revision like in my previous post.

Tried it on another plan:
- Latest cs is 23277
- Agent 3 last build 23276
- Run Customized with 23275 as the revision
- Agent 3 picks it up and updates to 23277 instead
 

Nothing else of much interest. Single stage and job in bamboo. First task is checkout repo. Repo using main branch, no other branches active. Repo is linked across all build plans. Seems to happen on all build agents and plans.

Share this post


Link to post
Share on other sites

Hi Tyler,

 

I have been working on this and trying to get it working as you are doing, but so far I haven't been able to set the changeset to build, as it only allows me to add a branch.

You can check it in the attached image. Can you tell me where are you adding it? 

Furhtermore, we released a task some time ago where the behaeviour of the "update" was changed. 

[New]

All platforms – Plastic, Gluon, command line: Now update always goes to latest.

Suppose you switched your workspace to a particular changeset, then decided to update. You were stuck on that changeset, by design.

We thought (for a few years already) that if you had switched to a given changeset, why would you want to jump to latest during an update?

But then we realized it was a true UX pain. Why wouldn't you want to switch to latest?

So, we just changed the behaviour. Now, when you update, you'll always go to latest in the branch, even if you were working on a given changeset or label before.

It was done the 2019-07-23, and released on version 3470.

Were you using a previous version when it was working?

 

Best,

Héber.

image.png

Share this post


Link to post
Share on other sites

Repo setup look fine. I'm doing a manual build with a custom revision set. https://confluence.atlassian.com/bamboo/running-a-plan-build-manually-289276898.html#Runningaplanbuildmanually-Runningacustomizedmanualbuild
1008749080_runcustomized.thumb.PNG.255e79e33fb8f0cc89fe418f20d811c4.PNG
 

Searched around and found a very old log with custom revision working from 2018. So yes, definitely was with a previous version but I can't say which one.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...