Jump to content
rlewicki

Cannot connect to server after admin web panel access attempt

Recommended Posts

Hi there, I've got an issue with connecting to server. Here is the setup I got and steps to reproduce the issue.

I've got server installed and setup along with the self-signed ssl certificate on my dedicated Linux server. When I try to connect to the server after fresh restart there is no issue at all.

Then, when I try to access web admin panel via browser entering http://hostname:7178 it  try to loads the site and then ends up refusing to connect. After this admin panel attempt when I got back to Plastic SCM software and I try to connect to server via Configuration tool it says: "Cannot establish connection because target computer actively reject the connection _hostname:8088_".

When I login to server and restart the server via _plasticsd restart_ command it works fine again.

The problem is, that since the server is dedicated server anyone from anywhere in the world can try to access this web panel which will break the connectivity to the plastic server for me and would require server restart.

Is it somewhat common issue? Is there a known solution to that? Can I disable web panel? Do you guys have any other suggestion?

Cheers!

Share this post


Link to post
Share on other sites

Hello, I'm afraid I haven't seen this in the past. The webadmin panel can be disabled in the "server.conf" but it shouldn't be necessary. Let's review the "plastic.dedbug.log.txt" to debug the issue.

  <StartWebAdminTool>false</StartWebAdminTool>

Regards,

Carlos.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...