Jump to content
kennethharder

Issues installing previous version on linux

Recommended Posts

Hi,

I am trying to install plastic 8.0 on Debian 10 and am doing so by following the direction available on https://www.plasticscm.com/plastic-for-linux but I cannot see any version below 9.0 from the apt repository. Should I be adding something else to the sources.list or is plastic 8.0 not supported on Debian 10? What am I missing?

Appreciate any help.

Share this post


Link to post
Share on other sites

Hi,

We only provide the most recent Plastic versions via Linux packages. You can install the last available 9.0 version.It would be compatible with your 8.0 Plastic clients.

Why would you need to install Plastic 8.0?

Regards,

Carlos.

 

Share this post


Link to post
Share on other sites

Hi Carlos,

Thank you for the quick response!

18 minutes ago, calbzam said:

We only provide the most recent Plastic versions via Linux packages.

Does that mean that we would have to perform a manual install to get version 8?

18 minutes ago, calbzam said:

Why would you need to install Plastic 8.0?

Our previous plastic machine broke and we are trying to restore from a backup and cannot seem to configure plastic 9 on our new machine to use the old MySQL data.

Share this post


Link to post
Share on other sites

Hi,

Only the last Plastic SCM versions are avilable to install via packages:

tester@ubuntu:~$ apt-cache policy plasticscm-server-core
plasticscm-server-core:
  Installed: (none)
  Candidate: 9.0.16.4330
  Version table:
     9.0.16.4330 500
        500 https://www.plasticscm.com/plasticrepo/stable/ubuntu ./ Packages
     9.0.16.4329 500
        500 https://www.plasticscm.com/plasticrepo/stable/ubuntu ./ Packages
     9.0.16.4321 500
        500 https://www.plasticscm.com/plasticrepo/stable/ubuntu ./ Packages
     9.0.16.4317 500
        500 https://www.plasticscm.com/plasticrepo/stable/ubuntu ./ Packages
     9.0.16.4312 500
        500 https://www.plasticscm.com/plasticrepo/stable/ubuntu ./ Packages

There shouldn't be any problem to configure Plastic 9 with MySQL. You need to use the same configuration ("db.conf" and "server.conf"). If you are getting any specific error, please attach the server debug log.

Regards,

Carlos.

Share this post


Link to post
Share on other sites

Hi Carlos,

We ended up getting the original machine working again, but good to know that it will be possible to upgrade to version 9 with our current setup if it becomes a necessity.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...