Jump to content
Sign in to follow this  
Geert Lowet

No conflicts but "Process All Merges" does not work

Recommended Posts

I am trying to merge my (= Geert) latest version (changeset 91) with the latest version of Lawrence (changeset 95). (See included image Branch Explorer Situation).

I did manually resolve the conflicts which couldn't be resolved automatically. No conflicts are left.

My Merge screen (also included) tells me that 17 merges have to be completed.

Pressing the Process All Merges button should complete the merge (as also indicated by the documentation window below)

However, pressing the Process All Merges button keeps returning me to the same situation, leaving me with an uncompleted merge.

How can I solve this?

 

 

 

 

 

Branch Explorer Situation.JPG

Merge Screen.png

Share this post


Link to post
Share on other sites

Hi,

- So you are locked and you are not able to finish the process of the merge? I haven't seen this behavior in the past If you have a commertial license, you can reach us at support@codicesoftware.com and we can arrange a meeting.

- Are you using Xlinks? Meantime you can also try to run the merge via console: "cm merge --help" command. We will also need to check your Plastic client logs.

- Are you using a recent Plastic SCM version? Because for we release a new months ago a new view that ease the workfllow when multuiple users are working on the same branch and avoiding to resolve merge conflicts, and this way, keeping a linear history..

http://blog.plasticscm.com/2019/10/incoming-changes.html

Regards,

Carlos.

Share this post


Link to post
Share on other sites

Thank you calbzam.

I did some further investigation.

Checking the Deleted Section in Pending Changes actually pushed the process.

To my opinion, the files shown had nothing to do with deleted files (they remaining files were added only on the source side, so an automatic merge would was expected for those files). But somehow checking the deleted checkbox triggered the Process All merges in a way it completed normally.

The merge was ok as was the final result set.

So the problem is solved although I can not explain why it was stuck.

Thanks for your contribution!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...