Jump to content

SocketConnectTimeoutMillisec Comes Up


Plasma
 Share

Recommended Posts

As the release notes state here (https://www.plasticscm.com/download/releasenotes/8.0.16.3841) to increase the default timeout to add the key "SocketConnectTimeoutMillisec" to client.conf.

I'm using Plastic SCM Cloud. I get this message when trying to look into sync view and under "Preferences" in the "Connection Profiles" page to check server the connection. I don't have this error during any push/pull. I only got this error recently and never had this problem.

In the release notes it shows how to modify the remote.conf, but not the client.conf as there is a different XML structure.

Adding <SocketConnectTimeoutMillisec>10000</SocketConnectTimeoutMillisec> to the client.conf has no effect, and copying the channel along with the children keys has no effect.

Remote.conf example:

<channels>
                <channel type="Codice.Channels.PlasticTcpChannel, plastictcpchannel" name="normal" timeoutMilliseconds="10000">
                    <clientProviders>
                        <provider type="Codice.Channels.ClientSinkProvider, plastictcpchannel" />
                        <formatter ref="binary" />
                    </clientProviders>
                </channel>

</channels>

I tried to look in Plastic SCM documentation for any sort of reference, but unfortunately could not find anything or perhaps I may have overlooked something under the documentation.

Link to comment
Share on other sites

The flag should can be included in both "server.conf" and "client.conf". 

Please restart the Plastic GUI and your local "Plastic SCM Server" Windows service and let us know if the issue persists.

<SocketConnectTimeoutMillisec>10000</SocketConnectTimeoutMillisec>

 

Do you  actually have some network issues that would explain the timeout error? Because the issue could be a different thing. Could you attach an screenshot to check how you have configured your sync view?

Regards,

Carlos.

Link to comment
Share on other sites

I finally resolved the issue I was having.

I checked literally everything. Firewall, ports, possibly antivirus, possibly a service causing the issue (had those before). Found nothing.

After I did a fresh install of Plastic SCM on a VM, I found out that in my preferences there was no connection profile.

I can't remember adding a connection profile, as I've only created a repo, check-ins, and sync views, but probably did on a drunken night.

Upon deleting the connection profile, I have no problems connecting to my cloud repos now.

If anyone is having this particular issue and how to find the connection profile: Preferences > Connection Profiles.

I appreciate you replying to my post, Carlos, but in the end it was my connection profile which most likely wasn't added correctly.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...