Jump to content

Udt timeout error when calling `cm lu` from the command line


Recommended Posts

I tried to call `cm lu` from the command line recently and I've been getting an odd error message. Specifically, I get this:
 

Quote

$ cm lu repserver:ssl://my.domain.com:8088
Error: Udt can't connect to [my.ip.address.here:8088] after 3000 ms. To increase the timeout set SocketConnectTimeoutMillisec in client.conf. Configure server.conf if the timeout happens during push/pull

 

Our PlasticSCM instance is reachable and is running. It is sitting on an instance behind a VPN. I can access its webadmin portal, and other commands, like 'cm showacl repserver:ssl://my.domain.com:8088', work perfectly fine.

I see that there is a slider for Udt on our server (also running Ubuntu Linux, like me). I tried setting it but it didn't seem to help at all.

My local `cm` version is 9.0.16.4437, and the server version of `cm` is 9.0.16.4107. Is it possible that I need to update the server to make this (and possibly other commands) work?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...