Jump to content

Error - Can't connect to [useast] cloud server?


JoshKAttainment
 Share

Recommended Posts

Hi! Our team uses PlasticSCM Cloud edition. I'm using the Windows version,  9.0.16.4456. Every time I attempt to view repositories, see pending changes, view branch explorer etc. I get this error:

'Can't connect to [useast4-00-cloud.plasticscm.com:10501] after 3016 ms. To increase the timeout set SocketConnectTimeoutMillisec in client.conf. Configure server.conf if the timeout happens during push/pull.'

I've tried verifying that the ports are open and tried updating my client, but no luck. Is there a way we can increase timeout for our Cloud account? Any advice would be appreciated.

 

Link to comment
Share on other sites

Hi,

I don't think it's a timeout problem but the client is not able to reach the server. Or are you connecting via a very slow network?

- In the client preferences, is the "Check connection" working?

- Could you run the following command to try to list the repos?

cm lrep YourOrganziation@cloud

Regards,

Carlos.

Link to comment
Share on other sites

Thanks for your reply. In client preferences, I tried these things:

- General > Check credentials (success)

- Connection Profiles > select the profile,  Edit > Connect ("Can't connect to [useast4-00-cloud.plasticscm.com:10501] after 3000 ms. To increase the timeout set SocketConnectTimeoutMillisec in client.conf. Configure server.conf if the timeout happens during push/pull")

- Configure your credentials > Check ("Can't connect to [useast4-00-cloud.plasticscm.com:10501] after 3000 ms. To increase the timeout set SocketConnectTimeoutMillisec in client.conf. Configure server.conf if the timeout happens during push/pull")

- $cm lrep attainment@cloud  (Error: Can't connect to [useast4-00-cloud.plasticscm.com:10501] after 3000 ms. To increase the timeout set SocketConnectTimeoutMillisec in client.conf. Configure server.conf if the timeout happens during push/pull)

Link to comment
Share on other sites

Hi,

It seems that something network related is preventing you to connect to the cloud organization. A firewall?

 This is what I get when I run this command:

C:\Users\carlos>cm lrep attainment@cloud
Enter credentials to connect to server [attainment@cloud]
User:

Regards,

Carlos.

Link to comment
Share on other sites

Thanks, that makes sense. In Windows Defender Firewall, I tried opening ports 10500, 10501 and 8086 as described in this page: https://plasticscmsupport.zendesk.com/hc/en-us/articles/360012428753-Can-t-reach-the-Plastic-SCM-Cloud-server

Unfortunately I'm still seeing the same error message. Are there any ports I should be aware of? These are for TCP, right?

Link to comment
Share on other sites

Hi,

- Do you have somewhere in your cliente configuration somewhere manually enteder the "10501". You shouldn't use any port in your client configuration. In order to connect to the cloud organization the spec is: OrganizationName@cloud.

- Could you remove the following file and reopen the GUI:

C:\Users\xxx\AppData\Local\plastic4\cloudregions.conf

- Could you also open the following ports and check if it makes any difference?

If the issue persists, I think it would faster to arrange a meeting and review your setup.

Regards,

Carlos.

Link to comment
Share on other sites

  • 2 years later...

I have been having this same issue for a couple weeks. Even though it's 2+ years later. 😏 I think it's because of my local network, haven't found anything wrong there yet. I have deleted cloudregions.config and restarted Plastic. That didn't appear to help. my cloud regions config has only commented out notes in it. It doesn't define anything. Could that be my issue? Is there a uswest server that I could try? Asking from Denver :D

Link to comment
Share on other sites

Thank you for the response Ollie! That is good to now. 

I just found the issue I was having on my local network. My VS added it's own VPN and it had a option for automatically activating in on start up. I chased my tail on it for a while because I would deactive it and Plastic would work for a few days until I rebooted again. I didn't see the correlation for over a week. 

Turning VPN off completely has given me access to Plastic's Server again. 

TIL: Plastic and VPNs are not compatible?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...