Jump to content
Pierre

Selector (bug ?)

Recommended Posts

Hi,

I get an error message which I don't understand.

I've been moving some files around (about 40 sound files). I've tried checking in only the files that I modified, but I still get the issue.

I am a free user, working on a local workspace alone on my project

Any ideas ?

KR

 

 

selector.png.87a95171b91e67fb10a42863dca5da12.png

Share this post


Link to post
Share on other sites

I have moved some directories. Could this be the reason for the error message ? Do I need in this case to do an "update workspace".

I am not sure what the "update workspace" does, I am afraid it will change files in my project.

Share this post


Link to post
Share on other sites

Solved.

The issue has happened when I tried to move some folders containing some sounds into another folder called "Sounds", so I had all my sounds in one folder.

I was able to solve it by copying the above mentioned moved folder into their previous place. A checkin was then possible without errors. After that, I removed the files and the folders and did a checkin after deleting the content of a folder or the folder itself, and I had no more issues.

I hope this helps you reproducing and fixing the issue. I love the tool and should start to use it for work soon (I use it at the moment for a hobby project)

Share this post


Link to post
Share on other sites

Hi,

Do you have any steps to reproduce the issue? Is it easy to reproduce in your environment? 

We have been trying to reproduce moving multiple folders and deleting items but we can't reproduce it.

Are you using the Unity plugin or moving the folders via Windows explorer?

Regards,

Carlos.

Share this post


Link to post
Share on other sites

Hi,

I think I used both unity plugin (the project view) and windows explorer to move the files.

Under Resources/, I had 3 folders with sounds. I moved all folders under a single folder. I changed also some other files.

Then the check in gave the error message. When I copied all the sounds folders in their original places, the message disappeared and I was able to commit. Then I was able to delete the copied folders and check in without error messages.

I'll check if I can reproduce it to give you a more step by step approach with screenshots.

Pierre




 

Share this post


Link to post
Share on other sites

Ok :(

We will keep an eye on it. If you find a way to somehow reproduce it again, please let us know.

Sorry for the inconveniences,

Carlos.

Share this post


Link to post
Share on other sites

@calbzam I noticed a few posts with this issue so didn't want to make a new thread. My repository is currently in this "selector error" state. I can avoid touching it if you wanted a look, or I can mail you my logs? (rather not post them online).

Glenn

 

Share this post


Link to post
Share on other sites

Could you reach us with the error screenshot and client logs at support@codicesoftware.com?

Regards,

Carlos.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...