Jump to content



Recommended Posts


I've setup jenkins on a local mac and after doing the initial setup process and creating a job, it's now failing with these errors :

16:53:53 Running as SYSTEM
16:53:53 Building in workspace /Volumes/Samsung_T5/Plastic Projects/Cases_Jenkins
16:53:53 [Cases_Jenkins] $ /usr/local/bin/cm workspace list --format={wkname}#{path}#{wkid}
16:53:53 shell-init: error retrieving current directory: getcwd: cannot access parent directories: Operation not permitted
16:53:53 Error: Plastic SCM client is not correctly configured for the current user: Client config file /var/root/.plastic4/client.conf not found. Please execute 'clconfigureclient' to perform a text mode configuration or 'macplastic --configure' for graphical mode.

The issue I have is, I don't know where clconfigureclient is (executing from terminal leads to command not found), however if i run macplastic --configure, it works and I setup everything but the same error keeps showing up on the jenkins job.

Any help would be appreciated.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...