Jump to content

There has been an unexpected error "Could not find a part of the path


emile.swain
 Share

Recommended Posts

Hi, I've been trying to work out why on the browser cloud page the usage details for a cloud repo were zero MB. Regardless of how many times i commited locally. Seems that what i thought i was doing wasn't in fact what i was doing. 

So i eventually got to a point where my sync view was setup and showed what looked like it was going to push changes to the cloud. 
But now i get the following error below. Note i checked the logs and there is nothing in them that suggest any error, or anything in fact relating to an unexpected error,  or not being able to find a path. The logs by all accounts look perfectly fine.

I should note, that due to originally setuping up plasticSCM with my Unity Account, which apparently doesn't work (or at least it still doesn't for me) with plasticSCM, i subsequently had to create another account. I'm also a part of two separate cloud organisations. Which just makes things even more confusing than they already are. 

Also, i have no idea why /mnt/ which is a unix thing is right? appearing as an issue on my PC. Unless this is an issue on the server side?

 

=================================================================

The sync process was unable to replicate the following branch:

Branch: /main
Operation: Push
Source repository: MissionManager@Emile@cloud
Destination repository: Test@Emile2@cloud

Error description: 
There has been an unexpected error "Could not find a part of the path '/mnt/metadata/jet/org_9158/rep_149474/replica/replicationlogs.dat'.". For more information check the server log.

=================================================================

 

Link to comment
Share on other sites

Hi,

- I think we should try understand why you cannot use your original cloud organization. I think it doesn't makes sense to have two organization for your personal development.

What is the problem you are having when logging with your Unity ID? Even with that, you can invite your new user to the same original cloud organiaztion (instead of creting a enw cloud organization).

- On the other hand, it seems to be a problem with one of the cloud organiaztions when cponfiguring the replica. Are both recently created organizations?

- Are you a paying customer or are you evaluating Plastic for your team? In that case, we could arrange a meeting to debug your issue.

Regards,

Carlos.

Link to comment
Share on other sites

 

Hi,

Quote

 

- I think we should try understand why you cannot use your original cloud organization. I think it doesn't makes sense to have two organization for your personal development.

What is the problem you are having when logging with your Unity ID? Even with that, you can invite your new user to the same original cloud organiaztion (instead of creting a enw cloud organization).

 

I think this has been resolved with updating the plasticSCM to version 10, which did over the weekend.

https://plasticscmsupport.zendesk.com/hc/en-us/requests/25556 Ticket i raised to get it resolved. 

 

Quote

- On the other hand, it seems to be a problem with one of the cloud organiaztions when cponfiguring the replica. Are both recently created organizations?

relatively yes.

Also, and i can't quite fathom from the ui whats what, but i thought i had setup this particular project to work with the centralised workflow. I assume this by the fact the workspaces repo is called MissionManager@emile@cloud and not MissionManager@local. 

1108013769_2021-04-1214_01_16-PlasticSCM-WorkspaceExplorer.png.aa6f37c5c8bbf04e4e12b250c72e258b.png

I assumed that when i checked in my code, that this would automaticaly sync changes to the cloud. but as far as i can tell, it doesn't. As you can see below, the project is zero GB. 

40371695_2021-04-1214_03_30-PlasticSCM-Organizationusage.png.101e4851f62eedc21c18ef54060dc460.png

 

So i think i'm working centralised, but its hard to really know what to look for to know if i really am or not. So i tried to do a sync view. 

740786859_2021-04-1214_05_30-PlasticSCM-Syncrepositories.png.650726f8a5246151f04e9604f785658e.png 

Now the above IMHO doens't make any sense because i think i'm working with a centralised workspace, but it online it doesn't reflect the size of my actual repo.

 

Emile@cloud is my Unity account, which i set up originally, then i had to switch to another account Emile2@cloud (with a different login that worked) and i setup a sync view to push the repo to that cloud repo. 


1099078750_2021-04-1214_08_38-PlasticSCM-Syncrepositories.png.a937684598ef943d6f3ddaf511b5d8f1.png
I thought, hey progress, i can finally actually push something off site. But no. i get the following error.

1525991366_2021-04-1214_09_43-Therehasbeenanunexpectederror_Couldnotfindapartofthepath-General.thumb.png.1c2fa8e3aef598d2db4638f10db0002a.png

 

I'm inclined to delete everything and start from scratch. I'll likely switch away from working centralised as i don't usually work that way anyway, and to be honest the only reason i ended up in that workflow is because i just don't follow/understand the plasticSCM UI at all. 

 

Quote

- Are you a paying customer or are you evaluating Plastic for your team? In that case, we could arrange a meeting to debug your issue.

My other account is a member of an Org as a paying customer. I will switch that account to my unity account and raise a ticket.

 

2021-04-12 14_00_50-Plastic SCM - Workspace Explorer.png

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...