Jump to content

Teamcity never finish test


Recommended Posts

HI,

 

I'm currently integrating Plastic SCM into Team city. I've moved client.conf to the program files directory. Our ssl certificate has  the following issue:

hostname server certificate doesn't match the server hostname 

I think this causes the teamcity plugin to hang. If so, I was wondering if it's possible to ignore this ssl issue?

Could this be fixed with serveralias.conf? 

Link to comment
Share on other sites

Hi,

If you are connecting a Plastic client to a server via SSL, the hostname needs to match with the server included in the certificate? Why you are not using the same name?

Regards,

Carlos.

Link to comment
Share on other sites

yes issue internally here. will be fixed. I'm just searching for a temp workaround. The main problem is for me is that TeamCity plugin doesn't show any info about this. Still didn't validate it if it's an issue

Link to comment
Share on other sites

Hi,

As a temporary workaround, you could configure the Plastic client installed in the TeamCity machine to reach the TCP port (8087) instead of conencting via SSL (8088).

This way, there won't be a a warning about the certificate not matching the server name.

Regards,

Carlos.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...