Jump to content

Unable to connect to euwest and start using plastic


Recommended Posts

First things first, I'm trying to use Plastic for the first time and migrate my game project to it.

I am currently subscribed to the free cloud version, and I downloaded the plastic cloud client.

However, when I try to do anything it's saying I am unable to connect to the server:

Can't connect to [euwest4-00-cloud.plasticscm.com:8088] after 3011 ms. To increase the timeout set SocketConnectTimeoutMillisec in client.conf. Configure server.conf if the timeout happens during push/pull

I tried messing around with preferences in the gui and googled for any solutions but I cannot seem to figure it out. As it isn't my user@org not connecting, instead it's the Plastic Cloud server??? It appears in the plastic scm gui, in gluon and when setting up the workspace upon opening plastic scm for the first time!

Anyhow, it's probably a beginners issue, hopefully I can resolve this and start migrating to Plastic SCM. Thank you!

Link to post
Share on other sites

Hey,

Thank you for pointing me in the right direction! I managed to figure it out and it seems to be properly connected now! Here is what I did to fix it:

  1. Found out how to start server manually from CMD, it quit with an error saying to check my .NET Core prerequisites.
  2. Installed those, updating windows, installing multiple C++ Redists and a certificate.
  3. Restarted and tried to start service/server/daemon from CMD again, which resulted in it saying a server.conf is missing.
  4. Went through config setup in CMD.
  5. Service was up and running finally, but I still had errors.
  6. Tried removing cloudregions.conf but it was to no avail still.
  7. Completely wiped my configuration folder: C:\Users\myuser\AppData\Local\plastic4 .
  8. Finally managed to log in and connect to my cloud org and repo with no issues.

Finally I can get around to using Plastic, I can't say it's not my fault as I am currently running on an older Windows 7 laptop as I do not have access to my main machine now and it's probably to blame. Anyhow, what's important is that it's working now.

Thank you again,

Nikola

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...