Jump to content

Error replicating branch on sync process - Source branch has two heads


Duardo
 Share

Recommended Posts

I created my repository a few hours ago and I'm trying to sync it from local to cloud for the first time (I'm using distributed version control). When I first tried to push the outgoing changes, the Sync failed because I had to first pull the incoming changes. So I successfully did that, and then I tried pushing again. This time, however, the branch replication failed because "The source branch has two heads", and I should "Merge from cs:af2f3159... [name continues] to br:/main to unify the heads". The problem is that I can't seem to find this "cs:af2f3159" etc. head anywhere to merge it with br:/main. I already tried to merge changesets both from the Changesets screen and from the Branch Explorer, but I'm always told that "The merge search has finished; merge destination already contains source changes", with no conflicts to solve or changes to apply.

This is how my my Branch Explorer looks like:

image.png.b82c05480756708357ff1a5ce9d7d678.png

Any help would be appreciated.

Edited by Duardo
I wrote "trying to" twice
Link to comment
Share on other sites

Could you let us know some more details about the error you are getting? Are you able to access to the rest of the repos?

We need to understand if the problem is configuration related (so you cannot access to any repo) or if you may have some restriction (eg: permissions) to access this specific repo.

Uninstalling Plastic shouldn't help.

If you are a paying customer, please open a ticket in support@plasticscm.com and we can even arrange a meeting.

Regards,

Carlos.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...