Jump to content

Why am I receiving "WorkspaceInfo cannot be null" error message, despite no changes to file directory?


Lashes
 Share

Recommended Posts

I'm not sure why I'm receiving this Error:
"WorkspaceInfo cannot be null"

What I did:
- Worked a few hours on my project in Unity;

- Directed attention again to the Plastic window (which had been open / running the entire time, and which I had successfully been using to push changes all day);

- Expected the Pending Changes window to be full of my changes to Checkin, (as I had been doing all day until now), but I instead found the Pending Changes window to be empty;

- Clicked "Refresh" in Pending Changes, and received the error message, "WorkspaceInfo cannot be null".

 

I see that there are other topics suggesting that this appears from a change in the file directory, but as far as I can tell, this has not been changed in my case.

I can view all files in the Workspace Explorer through Plastic, and also see them all in the File Explorer -- All the files in the project are in the same place I left them, as to be expected.

 

My attempts to resolve:

1 - Close Plastic and Re-open:

Result >> No changes to issue.

2- Restart computer:

Result >> No changes to issue.

3- Make new workspace directing to the project folder:

I received a message saying the workspace already exists, and was unable to create the new workspace.

Result >> No changes to issue.

4 - Make backup of project and create new workspace to this new backup project folder:

I received the same message as above saying the workspace (naming the original, not this new backup workspace I've just defined) already exists. I was unable to create the new workspace.

Result >> No changes to issue.



Can anyone suggest why I would be receiving this error message, and how to resolve the workspace so that I can continue to 'Checkin' changes?

image.png.14b670a327058558178b77936f9a5d09.png

Link to comment
Share on other sites

Well.. I've resolved the issue!
I'm not sure which step actually resolved the issue but continuing from steps above, I...


5 - Upgraded to the latest Plastic version.

>> Still had same error message in the "Pending Changes" window.


6 - Closed the Pending Changes window and re-opened.

>> Success! No more error message! All my pending changes are visible and I was able to Checkin.

Link to comment
Share on other sites

1 hour ago, calbzam said:

Hi,

Thanks for the update. It's a bit strange. If a similar issue happens again, we will need to review the client logs to debug it.

Regards,

Carlos.

Sure thing - I'll reach out again if I ever encounter a similar issue. Thanks!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...