Jump to content

Jira integration per-repo using plastic-global-config (cloud)


Luke.Sigtrap
 Share

Recommended Posts

Hi, I've been able to successfully set up the Jira integration from Plastic Cloud locally, but can't seem to get it to work globally.

I set up the Jira integration from the Windows GUI via Preferences/Issue Trackers (with "Apply binding to" set to Repositories, the only other option being default@local - not sure why the specific repo doesn't appear) and that worked. However I want it to be automatically set up for all clients. So I've tried putting the resulting jira.conf in plastic-global-config on my org's cloud server (the same server as the repo I want integrated with Jira) as follows:

MyTargetRepo/issuetrackers/jira.conf

WorkingMode=TaskOnChangeset

Name=Host;Value=https://XXXXXXXXXXX.atlassian.net;Type=Host;IsGlobal=True
Name=User name;Value=XXXXXXXXX@XXXXXXXXX.com;Type=User;IsGlobal=False
Name=Password;XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX;Type=Password;IsGlobal=False
Name=Branch prefix;Value=;Type=BranchPrefix;IsGlobal=True
Name=Project Key;Value=XXXXX;Type=Text;IsGlobal=True
Name=Custom Field ID;Value=;Type=Text;IsGlobal=True
Name=Use LDAP credentials if available;Value=False;Type=Boolean;IsGlobal=False
Name=Use default proxy credentials;Value=False;Type=Boolean;IsGlobal=False
Name=Issue query limit;Value=50;Type=Text;IsGlobal=False
Name=Resolved issue states;Value=Done;Type=Text;IsGlobal=True
Name=Issue types;Value=;Type=Text;IsGlobal=False
Name=Fields mapping;Value=;Type=Text;IsGlobal=False
Name=REST URL;Value=/rest/api/2/;Type=Text;IsGlobal=True
Name=Task URL;Value=/browse/;Type=Text;IsGlobal=True
Name=Status transitions;Value=;Type=Text;IsGlobal=True

Then I deactivated the local Jira integration from the PlasticSCM preferences/issue trackers GUI. I also removed the <Extensions> entry from my local client.conf.

Upon commiting this to plastic-global-config and restarting the GUI, AppData/Local/plastic4/globalconfig/xxxx@cloud/MyTargetRepo/issuetrackers/jira.conf appears correctly. However, the integration does not appear in the GUI and the <Extensions> entry in client.conf doesn't appear either. None of this happens for other people with access to MyTargetRepo either.

Am I missing something? Is automatic setup for all clients not possible? Do the above settings need modification somehow?

Link to comment
Share on other sites

  • 6 months later...
On 11/3/2021 at 6:05 AM, calbzam said:

This is a known issue. We should have a fix soon.

In summary, there is not a good way at the moment to share the JIRA configuration via the Plastic global repos if you are using a cloud server.

Is this still an issue? I'm having this same basic problem and am trying to understand whether it's on Plastic's side or mine.

Link to comment
Share on other sites

Hi,

Even when there is not a definited fix, the is the following workaround that should help:

Quote

We have found a workaround for this issue that should require a version upgrade.

We need to edit the "C:\Users\xxxx\AppData\Local\plastic4\client.conf" and replace "local" by "MK4Gaming@cloud".


The problem here is the following: by default, Cloud Edition is connected to local. Which is good for distributed development.

By default, I actually mean the server in your client.conf. This is the one we use for Issue trackers.


Please let us know if it helps.

Regards,

Carlos.

Link to comment
Share on other sites

Hey there!

I'm also having the same issue pushing a global Jira config to cloud clients. I'm on the latest version of Plastic (11.0.16.6994) on Windows. 

The above workaround does not appear to work. Any help here would be greatly appreciated! Thanks!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...