Jump to content

Unity Integration on Linux


JVetulani
 Share

Recommended Posts

After the forced migration from collaborate to plastic (which we are very unhappy with as it happened in the middle of the week with zero warning from collaborate in Unity beforehand...)
Two people in the team using Unity on Linux (Ubuntu 20.04) have issues about a missing file in Unity:

The window displays a similar error:
Could not find a part of the path "/home/myUser/Projects/Unity/NameOfMyProject/Packages/com.unity.render-pipelines.universal@10.7.0/-Textures/Packages/com.unity.collab-proxy/Editor/PlasticSCM/Assets/-Images/d_iconundo.png".

However the path keeps changing after we press Reload.
We tried changing to newer versions in the Unity Package Manager under Version Control, and the Plastic SCM window pops up for a second and then the error pops up again, the contents of the window disappear and we cannot use Plastic at all.

This issue does not come up for people in the team on Windows.

This is on Unity 2020.3.22f1
We start unity through the Unity Hub.

We also tried downloading the Plastic SCM client directly, checking out the project from there and adding it to Unity Hub, but that generated issues with packages and a missing "Normcore" package.


 

Link to comment
Share on other sites

The problem has been fixed, for now, by adding the line:
"com.unity.nuget.newtonsoft-json": "2.0.0"

To manifest.json

It was one of the dependencies in the project that was removed by the removal of collab.
Once the errors in the projects resolved themselves the Plastic SCM window started working, using the latest version.

It is interesting that this did not happen on Windows.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...