Jump to content

[HELP] Plastic SCM triggers not firing?


Erk
 Share

Recommended Posts

Hi,

I am having som issues setting up our CI environment.

What we want:
- A client checks in and pushes some change to a branch.
- Plastic fires a trigger to jenkins.
- Jenkins recieves trigger and starts a job. 

What we currently have:

- Jenkins, a job which can be triggered manually and remotely in my webbrowser using "JENKINS_URL/job/JOB_NAME/build?token=TOKEN_NAME".
- Plastic SCM plugin, branch data is checked out during job build.

 

My issue is that Plastic does not seem to trigger the url properly as a payload?
I've tried to creating a trigger via the dashboard
(I've also made sure that jenkins is accessible from outside the localhost with ngrok)
image.thumb.png.d6cf53b1da9484b1ca3ab8888ccf0f35.png 

 

and I've also tried creating them in the command line.. What am I missing or doing wrong? 

I

 

Link to comment
Share on other sites

I tried sending the same payload via postman as a POST-request and I seem to be getting the error
'HTTP ERROR 403 No valid crumb was included in the request'. 

I see a lot of solutions for this issue using GITHUB, but not much for Plastic.. 

Link to comment
Share on other sites

Got it working in Postman using
cm maketrigger after-add "Start-Build" "webtrigger http://<Jenkins-User>:<Jenkins-user-API-Token>@Jenkins-server:8080/job/<Jenkins-job>/build?token=<Jenkins-user-API-Token>"

However, still not working with plastic...

Link to comment
Share on other sites

  • Erk changed the title to [HELP] Plastic SCM triggers not firing?
  • 3 months later...
On 5/20/2022 at 7:01 AM, ollieblanks said:

Hmmmm... interesting problem.

Is the workspace you are using connected to your Cloud server in a centralised manner? If you are using a Sync view to work in a distributed workflow then the trigger would not fire.

I am using sync view.  What is the solution to get triggers to fire?

Link to comment
Share on other sites

  • 1 month later...

If you are using a sync view that means that your workspace is pointing at your local server. If you want to have a trigger fire you need to configure it on your local server.

Unfortunately, this is a known limitation of using Plastic in distributed mode. Is there a reason why you are not using Plastic in centralised mode? (workspace linked directly to a remote server)

Hope this helps!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...