Jump to content

Installation error


Recommended Posts

When i try to install plastic scm on Ubuntu 22.04 LTS i get this

sudo apt-get install plasticscm-cloud
[sudo] password for :
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 plasticscm-client-core : Depends: liblttng-ust0 but it is not installable
                          Depends: libicu52 but it is not installable or
                                   libicu55 but it is not installable or
                                   libicu57 but it is not installable or
                                   libicu60 but it is not installable or
                                   libicu63 but it is not installable or
                                   libicu66 but it is not installable or
                                   libicu67 but it is not installable
 plasticscm-client-gtk : Depends: liblttng-ust0 but it is not installable
                         Depends: libicu52 but it is not installable or
                                  libicu55 but it is not installable or
                                  libicu57 but it is not installable or
                                  libicu60 but it is not installable or
                                  libicu63 but it is not installable or
                                  libicu66 but it is not installable or
                                  libicu67 but it is not installable
                         Depends: plasticscm-gnome-sharp-mono4 (>= 2.24.0) but it is not going to be installed
 plasticscm-server-core : Depends: liblttng-ust0 but it is not installable
                          Depends: libicu52 but it is not installable or
                                   libicu55 but it is not installable or
                                   libicu57 but it is not installable or
                                   libicu60 but it is not installable or
                                   libicu63 but it is not installable or
                                   libicu66 but it is not installable or
                                   libicu67 but it is not installable

How do i fix this problem?

Link to comment
Share on other sites

Hi,

There are some tweaks we are working on before being able to upgrade those libraries and the team is currently working on it.

Hopefully we have a fix soon.

 

Best,

Héber.

Link to comment
Share on other sites

  • 1 month later...

I get similar errors when I try to just install the plasticscm-proxy-server:

sudo apt-get install plasticscm-proxy-server
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 plasticscm-proxy-server : Depends: liblttng-ust0 but it is not installable
                           Depends: libssl1.1 but it is not installable or
                                    libssl1.0.0 but it is not installable
                           Depends: libicu52 but it is not installable or
                                    libicu55 but it is not installable or
                                    libicu57 but it is not installable or
                                    libicu60 but it is not installable or
                                    libicu63 but it is not installable or
                                    libicu66 but it is not installable or
                                    libicu67 but it is not installable
E: Unable to correct problems, you have held broken packages.

We have a client who would like us to use the proxy server to speed up builds and I would prefer to not to have to reinstall an older version of Ubuntu on this server or add packages from an older version.

Is there any update on the progress of adding Ubuntu 22.04 LTS support? We only need the proxy server, not any Plastic GUI toolsm so maybe you might be able to release an update for just that sooner?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...