Jump to content

plastic scm installation failing in ubuntu 18.04


Recommended Posts

Followed https://www.plasticscm.com/plastic-for-linux to install plastic scm cloud in Ubuntu 18.04(64), but failed with dependency issues while installing using
sudo apt-get install plasticscm-cloud

 

error
 

dpkg: error processing package plasticscm-client-gtk (--configure):
 installed plasticscm-client-gtk package post-installation script subprocess returned error exit status 127
dpkg: dependency problems prevent configuration of plasticscm-client-complete:
 plasticscm-client-complete depends on plasticscm-client-gtk (= 11.0.16.6979); however:
  Package plasticscm-client-gtk is not configured yet.

dpkg: error processing package plasticscm-client-complete (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of plasticscm-cloud:
 plasticscm-cloud depends on plasticscm-client-complete (= 11.0.16.6979); however:
  Package plasticscm-client-complete is not configured yet.

dpkg: error processing package plasticscm-cloud (--configure):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.27-3ubuntu1.5) ...
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          No apport report written because the error message indicates its a followup error from a previous failure.
                                        Processing triggers for systemd (237-3ubuntu10.53) ...

error.txt

Link to comment
Share on other sites

Hi,

 

Quote

Setting up plasticscm-gnome-sharp-mono4 (2.24.0) ...
Setting up plasticscm-client-gtk (11.0.16.6979) ...
/var/lib/dpkg/info/plasticscm-client-gtk.postinst: line 26: xdg-mime: command not found
dpkg: error processing package plasticscm-client-gtk (--configure):
 installed plasticscm-client-gtk package post-installation script subprocess returned error exit status 127
dpkg: dependency problems prevent configuration of plasticscm-client-complete:
 plasticscm-client-complete depends on plasticscm-client-gtk (= 11.0.16.6979); however:
  Package plasticscm-client-gtk is not configured yet.

Checking the error output, can you check if intalling the "xdg-mime" package helps?

http://manpages.ubuntu.com/manpages/impish/man1/xdg-mime.1.html

Regards,

Carlos.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...