Jump to content

[SOLUTION] There aren't any diff tools defined in the client configuration file


Gaidline
 Share

Recommended Posts

After upgrading Plastic to the newest version (11.0.16.7274) I encountered a bug blocking me from using Unreal external diff in Plastic.

I added Unreal external diff tool as follows:

image.png.979337e7b9dcd38ace171a45122e3438.png

Custom extension = .uasset
External tool = "C:\Unreals\UE_4.27\Engine\Binaries\Win64\UE4Editor.exe" "C:\Repos\ExampleProject\ExampleProject.uproject" -diff "@sourcefile" "@destinationfile"

It worked fine so far, but after the upgrade I tried to diff some Blueprints and an error appeared:
"There aren't any diff tools defined in the client configuration file"
But clearly there are. I can see the Unreal diff tool in the Diff tools settings.

I reinstalled Plastic few times, removed all config files but the error persisted.

I looked into the %LocalAppData%\plastic4\client.conf file and noticed that the <DiffToolData> section with my Unreal diff tool contains "<FileType>enTextFile</FileType>" sub-section. This is weird since I selected "Custom extension" in the Plastic diff tools settings. I removed this sub-section, leaving the "<FileExtensions>.uasset</FileExtensions>". And it worked 🙂

I don't know if it's a bug or just my config got corrupted. I spent few hours solving this issue and I decided to write about this in case somebody else has similar problem.

  • Sad 1
Link to comment
Share on other sites

  • 2 weeks later...

Hey hello,

Thanks for reporting this, I came to the same conclusion yesterday, but in fact the bug doesn't happen anymore to me:
It seems that it only affects the new PlasticX GUI and not the "legacy GUI", and switching to the legacy GUI fixes the config file.

I have reported this internally :)

Cheers!
Sébastien

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...