Jump to content

884 pending changes I didn't do, can't undo, commit, shelf, nor change branch.

Recommended Posts

I tried to checkout a branch that a coworker had been working on, and I think all the changes Plastic made to get me over to said branch ended up in my pending changes?

In either case, I've got 884 pending changes I didn't do.

If I try to undo them, I get: "The revision to load was not found"

If I try to jump to a different branch, or reload the current one, I get: "Cannot preform the switch to branch/label/changeset/shelve since there are pending changes. Please review the pending changes and retry the operation again."

If I try to shelve the changes, I get: Cant add an entry with the same name. Duplicated child [chapter_button.pretab]. Parent [AMenu]

If I try to commit the changes to some throw-away branch, I get: There has been an error "The item should be found on the server tree. Child [Little moments-1.png.meta]. Parent [cooking sprites]". For more information Check the server log.

If I try undoing the changes specifically to the files mentioned in that error: It will let me, but then throw the same error again, with new files.

Maybe following that trail for long enough will eventually let me commit to a throw-away branch, but I really feel like there should be a better solution than this.
Is there?

(I've obviously already tried pressing any and all refresh/reload/update/spinny-arrow-icon-buttons in the program, but this changed nothing)

EDIT: I've just re-downloaded the whole project, sidestepping the problem, but I am now very weary of changing branches. Whatever this was, I hope it doesn't happen again.

Edited by San Jacobs
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...