Jump to content

Can't register license on OS X client.


Recommended Posts

I'm using the latest Semanticmerge ( on OSX. Whenever I diff a file in PlasticSCM, it opens up Semanticmerge and asks me to input my license. Once I enter my license and click "Get License", it takes about a second then quits with the message "semanticmerge quit unexpctedly".


I tried multiple times, re-installed Semantic merge and still it crashes even after clicking "Get Trial" button.


I've purchased a license a while ago and never really got it fully set up until now, except for this issue. =/


Here's the full crash report:



Also, here are the contents of "semantic.log.txt" located in "~/.semanticmerge":


Link to comment
Share on other sites

Thank you! That only worked half-way, though...


Now, whenever I Diff a file in PlasticSCM (on OSX) it opens up the "Semantic Merge Tool usage" window instead of the diff window.


I used the default SemanticMerge setting in PlasticSCM > Preferences > Diff tools.

The custom extension is set to .cs


Here's the command I'm using:

"/Applications/semanticmerge.app/Contents/MacOS/semanticmerge" -s="@sourcefile" -sn="@sourcesymbolic" -d="@destinationfile" -dn="@destinationsymbolic" -i="@comparationmethod" -e="@fileencoding"


What's the problem here?

Link to comment
Share on other sites



In the last macplastic version, when configuring the external diff tool, if you select "Custom" --> "Semantic Merge" you will not need to manually enter the command. Just select "Semantic Merge" in the list and the command will be automatically generated.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...