Jump to content
Sign in to follow this  
indexPlastic

The Unity3D plugin is unlicensed in your Plastic SCM server

Recommended Posts

Hello,

 

We have licenses for 4 users of the "Enterprise" edition of unity, I have installed the license file in the server, which is reflecting the correct level of "Enterprise Edition"

 

Plastic Client Version: 5.4.16.686, Plastic Server Version: 5.4.16.685

 

When attempting to connect to the server from Unity (5.1.1f1, on Mac OS X 10.10.8) we are getting the following error "Version Control: PlasticSCM: The Unity3D plugin is unlicensed in your Plastic SCM server" and "Cannot load PlasticSCM overlays when plugin is not running"

 

I have seen some posts regarding this error and the community edition, which attribute this error to the licensing issue of community not being able to use the Unity plugin.  This is not the case.

 

Any ideas?

 

EDIT:  In the webinar for PlasticSCM + unity, when the speaker selects "PlasticSCM" in the Editor window, there are options for "Workspace" and "Repository", we do not see those options, are we missing something?

 

Results of the cm li command:

plasticLicense.png

 

We are seeing this icon next to the unityplugin application in the macplastic app

Screen%20Shot%202015-08-24%20at%203%2050

 

We've tried rebooting the MAC, and we have our security settings allowing applications from third parties, but this icon with the white circle and slash is still appearing next to the application.  When we run the application directly from the command line, we get the same errors we are getting above.

 

We are seeing these requests on the server

2015-08-24 19:50:16,528 00000000-0000-0000-0000-000000000000 NT AUTHORITY\SYSTEM at <removed>  Operations - Retrieving server license data
2015-08-24 19:50:16,528  NT AUTHORITY\SYSTEM at  INFO  ChannelCall - recb:   617|rect:  0|sentb:   509|sendt:  0|prt:       0|th:   32|dest:   0|mt:       0|sert:   0|zip:   0|    <ip address>|GetLicenseData
2015-08-24 19:50:16,622 (null) NT AUTHORITY\SYSTEM at (null) INFO  Channel - Connection   47 from <ip address> closed

Share this post


Link to post
Share on other sites
Hi Mark,

 

Could you type the word "false" in the Gluon field? 

 

Please, review that the user who runs Unity3D is the same who runs Plastic (you probably has only configured Plastic for a specified user).

 

Are you using Unity Pro version?

 

Best regards.

Share this post


Link to post
Share on other sites

Hi,

Could you open a console in the Unity machine and run "cm licenseinfo" and attach the output?

If you open the Plastic GUI are you able to work with your repos? We need to be sure the regular client is working and then debug the plugin issue:
https://plasticscmsupport.zendesk.com/hc/en-us/articles/360023725933--Cannot-retrieve-license-information-Error-message-at-the-Plastic-SCM-GUI

Best regards,
Carlos.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...