Jump to content
redwards

JIRA Issue Tracker preferences screen not saving Project Key - Man on the Moon

Recommended Posts

Repro steps:

 

Open preferences | Issue Tracker.

Branch prefix: ESR-

Project Key: ESR

 

change to 

Branch prefix: scm

Project Key: MULTIPLE_PROJECTS

 

Hit OK.

 

Open preferences | Issue Tracker. 

Old values are there, change not saved. 

 

Share this post


Link to post
Share on other sites
Hi,

 

It´s a known issue in the last Plastic version that we are going to fix. 

 

As a temporary workaround, you could enter the JIRA values, select a different issue tracker in the dropdown menu and finally select JIRA again. This way, the data should be propely saved.

 

Sorry for the inconvenences,

Carlos.

Share this post


Link to post
Share on other sites
I’ve figured out a verifiable method for associating JIRA with Plastic.

Basically I use a text editor to display the true contents of the config file.

I also save a copy of it in the good state so that I can quickly, and independent of the Plastic GUI, perform a replacement when it gets wiped out.

 

Here is what I have done in more detail:

 

jira.conf is located in

C:\Users\<MY_USERNAME>\AppData\Local\plastic4\issuetrackers\ssl_\<OUR_SERVER>\allrepos

 

Open jira.conf in notepad++ … now any changes will be detected and the notepad++ gui. This way I am not dependent on the Plastic GUI to report how things are configured. All I need the plastic gui for is to enter info, most importantly my JIRA password.

Open Issue Trackers in Plastic. Dropdown set to JIRA but fields blank. Hit “Test Connection”, which fails. Hit OK.

Go back to notepad++, which shows that jira.conf has indeed been changed. (I have no idea why my jira.conf was in a similar state this morning, but I know it was *not* because I did as described above)

In Plastic Issue Trackers, do the following:

Set issue tracker to Bugzilla (this is the critical "set to something other than JIRA" gymnastic from what I can see)

o Set issue tracker to Bugzilla (this is the critical "set to something other than JIRA" gymnastic from what I can see)

o Set issue tracker to JIRA

o Enter my info, test connection, hit apply, hit ok.

Go back to notepad++, which reports that jira.conf has changed. The contents are now correct. (VERIFICATION STEP 1 of 2: jira.conf contains what we have entered). This is important because reentering Plastic Issue Trackers displays blank fields.

Go to branch explorer, try to create a branch. Pending tasks should be listed. (VERIFICATION STEP 2 of 2: pending tasks visible)

Place a copy of jira.conf on my desktop. Moving forward, the next time jira.conf gets reset to neutral, I will just copy paste the good one.

 

Still no idea what is causing the file to be wiped out in the first place.

Share this post


Link to post
Share on other sites

This bug seems to have come back, but the solution isn't working any more. Jira no longer accepts username and password and needs a token instead (which you can use just like a username and password *I think*). But it won't save on version 8.0.16.3310.

What I'm finding is that it's saving it to the non-SSL version of the conf file, but then reading it from the SSL version.

My solution is:

  1. Set the values, test, and then save.
  2. Close Plastic GUI
  3. Go to c:\windows\users\[username]\AppData\Local\plastic4\issuetrackers\[non-ssl-server]\allrepos
  4. Copy jira.conf which should have today's timestamp
  5. Paste into c:\windows\users\[username]\AppData\Local\plastic4\issuetrackers\[ssl-server]\allrepos
  6. Re-open Plastic GUI

The new values are now present. (The new Jira integration still isn't working but at least it connects!)

 

UPDATE! This didn't work for a colleague who didn't even have an [ssl-server] folder. He's created his own and that has worked though.

Edited by notken
Feedback from another user

Share this post


Link to post
Share on other sites

Ok, so the problem is the JIRA settings are not properly saved and when you reopen the GUI the values are not there?

Are you configuring JIRA for all repos or for one specific repo? I will try to reproduce.

Regards,

Carlos.

Share this post


Link to post
Share on other sites

All repos. The values aren't *blank* but they were reverting to the old values. What seemed to be happening is that it was saving them to jira.conf in the Games_Press_Ltd@cloud/allrepos folder, but reading the values back from ssl_games_press_ltd@cloud/allrepos

 

Here's my jira.conf (minus the password):

WorkingMode=TaskOnBranch

Name=Host;Value=https%3A%2F%2F[removed].atlassian.net;Type=Host;IsGlobal=True
Name=User name;Value=[removed];Type=User;IsGlobal=False
Name=Password;Value=[removed];Type=Password;IsGlobal=False
Name=Branch prefix;Value=JIRA-;Type=BranchPrefix;IsGlobal=True
Name=Project Key;Value=MULTIPLE_PROJECTS;Type=Text;IsGlobal=True
Name=Custom Field ID;Value=10016;Type=Text;IsGlobal=True
Name=Use LDAP credentials if available;Value=False;Type=Boolean;IsGlobal=False
Name=Use default proxy credentials;Value=False;Type=Boolean;IsGlobal=False
Name=Issue query limit;Value=50;Type=Text;IsGlobal=False
Name=Resolved issue states;Value=Done%2CMade%20Live%2CChecked%20In;Type=Text;IsGlobal=True
Name=Issue types;Value=;Type=Text;IsGlobal=False
Name=Fields mapping;Value=issue.Fields.Description-%3EDescription%7Cissue.Fields.Reporter.Name-%3EOwner%7Cissue.Fields.Summary-%3ETitle;Type=Text;IsGlobal=False
Name=REST URL;Value=%2Frest%2Fapi%2F2%2F;Type=Text;IsGlobal=True
Name=Task URL;Value=%2Fbrowse%2F;Type=Text;IsGlobal=True
Name=Status transitions;Value=;Type=Text;IsGlobal=True
 

While the test connection is fine, none of the integrations are working any more. We're still looking into that.

Share this post


Link to post
Share on other sites

Hi,

Removing the "C:\Users\xxx\AppData\Local\plastic4\issuetrackers" folder and re-configuring the JIRA parameters in the GUI doesn't help? We may need to arrange a GoToMeeting session to review your setup. Please reach us at support@codicesoftware.com.

Regards,

Carlos.

Share this post


Link to post
Share on other sites

Hi Carlos. I downloaded yesterday's update as I saw there was mention of supporting Jira API keys, but now I can't even get a successful test connection to Jira. And still the plugin doesn't work.

I couldn't delete the folder because there was a lock on it, but I did manage to delete the jira.conf file and all but the ssl_games_press_ltd@cloud folders, and the preferences do now 'stick'.

Is this a known problem about the plugin and Jira's requirement to use API keys now? It doesn't look like the plugin works at all any more.

Share this post


Link to post
Share on other sites

Yes, from our JIRA guide: https://www.plasticscm.com/documentation/extensions/plastic-scm-version-control-task-and-issue-tracking-guide

  • User name and Password: Specify the JIRA credentials used to log into JIRA and log the changes. 
    If you use Atlassian Cloud, the User name must be the email address of the account, and the Password must be an API token. You can find out how to generate API tokens for your Atlassian Cloud account in their official documentation. 
    Note that these fields can be the user credentials in JIRA, or the credentials of a different JIRA user specifically created to log Plastic SCM changes. The issue history on JIRA will display the change as coming from the user configured here.

- If you are removing the "issuetracker" folder, please close the GUI first so the folder is not locked. Could you attach the Plastic client logs so we can review the error? I've just set up a JIRA cloud organization and everything seems to be working if I use the API token.

If you reach us at support @codicesoftware.com, we can arrange a GoToMeeting with you to debug your scenario.

Regards,

Carlos.

Share this post


Link to post
Share on other sites

Ah, OK, thanks, the email address as user name worked. I was using the name I gave the API token, which was giving a positive response to "Test connection" before. Yesterday's update stopped Test connection from working, accurately as it turns out!

The plug in is good for me again, and settings are being saved now I have no other jira.conf files or folders.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...