Jump to content

Simple move - Not appearing as latest changeset, no comment


Recommended Posts

Hi,

 

I'm trying to run a simple .bat file (see code below) to move a file to a subfolder. Everything has already been previously checked in.

 

When I use the CLI to do the move, everything seems to work out fine, but when I select the file in Gluon, you can see that the latest changeset is not bold (indicating that my checkin failed, I think) and that the comment I tried to add is not present. (See attached image.)

 

Any idea what's going on?

 

Thanks!

Dave

cd c:\project

cm partial configure -/ +/

set dst=c:\project\destination



cm partial checkout %dst%

cm partial checkout %dst%\subfolder

cm partial checkout %dst%\test.txt

cm partial move %dst%\test.txt %dst%\subfolder

cm findchanged -R . | cm partial checkin -c="Moved file"



pause

post-32143-0-34345700-1467764637_thumb.png

Link to post
Share on other sites
  • 2 weeks later...

Hi,

 

the checking operation worked fine, and the history view is showing you the revision you are loading which is the one bold since you're loading it's content. It's done in that way to allow you to revert to a certain revision content or compare revisions. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...