Jump to content

Deadlock after merging files


Recommended Posts


A coworker of mine is working in my team and he found himself on a situation of dead lock.

After performing a merge, he executed the application and then when he tried to perform the checkin, Plastic says that can't commit the checkin with partial checkin, but all the files in "pending changes" view are checked.

We can't undo changes or perform the checkin or switch branches in his machine. So, he is locked.

I tried to restart the server but nothing seems to help.

Can you help me?

Link to comment
Share on other sites


Please make sure that you open the Pending changes view from the left side of the main application window, and the filter textbox is empty.

Also you can use the command line client:

cd to the root of your workspace and type:

"cm ci" in order to submit the changes or

"cm unco" to undo the changes.

Plese let me know how it goes.

Link to comment
Share on other sites


using the command line that you told me the checkin was performed correctly.

But I still think it was a GUI bug, since I closed VS 2010, the client, stoped the service and still got the error.

The filter text was empty.


Link to comment
Share on other sites

Hi Pablo,

I cannot describe with details, but my coworker said that he performed a checkin, then he performed a merge.

He tried to perform the checkin operation via Plastic's Visual Studio 2010 plugin and he also told me that a window appear to him because a binary conflict with the ".suo" file. Then he choose his file and then he tried to perform the checkin (inside the VS). That's when the error message start to be shown.

I hope this could help you!

Link to comment
Share on other sites

Just to add some information, now happened with me:

I cloacked the .suo file in my workspace and it keeps showing in my machine as "modified".

I tried to undo the changes and nothing.

I performed the checkin, no error message was shown. but the file still was shown in the "pending changes" view.

I tried to delete the file and perform an update and the error was shown telling me that there was pending changes...

I opened the cmd and typed: cm unco

Everything worked fine. :)

This bug is happening from time to time now..

If I could help you more on this, just say! :)

Link to comment
Share on other sites

Hi cidico,

well I'm sure that having the .suo file on the source control system is a bad idea hehehe



Anyway we will try to reproduce the error.

Thanks for the feedback!


Link to comment
Share on other sites

Yes, I know.

It was grabbed from my machine by mistake.

Just to you know, I reproduced this error a lot when performing merge operation. Funny thing here is that it only occurs when there's a .suo file (I suppose the problem is when there are changes in binary files in the branch).

The GUI just don't do what we want. For example: The .suo file is deleted on the branch that I'm merging from, but my current workspace have on .suo file.

When I process the merge, all merge operations are done, except the deletion of .suo file. It keeps there forever and ever until I run the "cm ci" in the workspace.

Via GUI, the error message described is shown.

Now I finally did add the .suo file the cloacked list once for all!

Hope it helps!

Link to comment
Share on other sites

  • 4 years later...


This topic is now archived and is closed to further replies.

  • Create New...