Jump to content

Path Permissions Config Not Working


StefDevs
 Share

Recommended Posts

My last experience with support tickets was poor so let's try here, at least the solution will be discoverable to others...

This should be an extremely simple task, but I've been at it for hours and can't find a permissions configuration that works for my [extremely common] scenario. Either A: the system is not working as intended, B: the system is incredibly obtuse, or C: I'm incredibly dumb. Honestly I'm hoping for C.

What I'm trying to do is basically this: docs...Giveaccesstoaparticularsubdirectory,butnottheentiretree

I have a group Artists that I want to have write access (change, add, ci, etc) to only specific directories, and read access everything. I've tried all kinds of combinations of permissions: server perms, repo perms, path perms, allowed, denied, neither, overridden.. you name it, I've tried it and nothing has worked. They either have a permission set for everything or nothing. If I'm remembering correctly, path permissions have at no point had any effect at all, positive or negative.

It's really unfortunate that the documentation doesn't _actually explain_ how this system works, so I'm stuck doing trial and error instead. Like, what exactly is the inheritance hierarchy topology? What is the evaluation order? What is the default behavior? What is prioritized over what?

Anyway... I would very much appreciate it if someone could tell me exactly what my configuration for this group should be at each level (server, repo, root path, sub path) to have a single permission (ie: read access) allowed for a single sub-folder in the repository.

For context: I'm using cloud, Artist is the only group I have aside from Admin, I have no other rules set for any users or groups, and the user account I'm testing with (on a separate machine) is in the Artists group and is not an admin. The folder I'm trying to configure exclusive access to is in the root dir: @repo/art_source

To be sure, I just tried carefully following the linked tutorial again, and it did not work. Hopefully I'm just missing something...

Thanks.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...