Jump to content

Gitsync error "The response ended prematurely"


tahomasan
 Share

Recommended Posts

It was working just fine a couple of weeks ago last time I attempted to sync. I've tried reverting to the last working build of Plastic but still receive the same error. Here is the stacktrace:

 

2022-03-27 10:54:16,464 RIGBY\Scott ERROR sync - Error running sync: The response ended prematurely.. StackTrace:
   at System.Net.Http.HttpConnection.FillAsync(Boolean async)
   at System.Net.Http.HttpConnection.Fill()
   at System.Net.Http.HttpConnection.ChunkedEncodingReadStream.Read(Span`1 buffer)
   at System.Net.Http.HttpBaseStream.Read(Byte[] buffer, Int32 offset, Int32 count)
   at System.IO.BinaryReader.ReadBytes(Int32 count)
   at LibGit2Sharp.Pkt.parselen(BinaryReader reader)
   at LibGit2Sharp.Pkt.Parse(BinaryReader reader)
   at LibGit2Sharp.Remote.Download(String path)
   at Codice.Foreign.PackageDownloader.DownloadPackage()
   at Codice.Foreign.PackageDownloader.Download()
   at Codice.Foreign.GitPuller.DownloadPackage()
   at Codice.Foreign.GitPuller.GetRevisions(String gitMainBranchName)
   at Codice.Client.BaseCommands.Sync.GitSynchronizer.GetForeignChangesetsToPull(String gitMainBranchName)
   at Codice.Client.BaseCommands.Sync.GitSynchronizer.CalculateChangestsToSynchronize(ForeignReferences references, String gitMainBranchName, List`1& remoteChangesetsToPull, List`1& localChangesetsToPush)
   at Codice.Client.BaseCommands.Sync.SyncRunner.RunGitSync(SyncStorage storage, String gitMainBranchName, Boolean bJustPrint)
   at Codice.Client.BaseCommands.Sync.SyncRunner.RunSync(SyncSettings settings, RepositoryInfo repInfo)
   at Codice.Client.BaseCommands.Sync.SyncRunner.Sync()

 

plasticx.debug.log.txt

Link to comment
Share on other sites

  • 1 month later...

Hi @tahomasan,

This error can be related to the restrictions on GitSync. Can you please take a look at the link I have attached and check if this is relevant to your situation?https://www.plasticscm.com/documentation/gitsync/plastic-scm-version-control-gitsync-guide#GitSyncrestrictions 

Please check if the issue persists when you attempt to gitsync with clean new repo.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...