Jump to content

Troubleshooting the UE4.27 plugin


Recommended Posts

I've tried both steps: extracting the 4.27 plugin to my project folder AND my UE4 install directory (removed one when trying the other of course). In neither case did the plugin appear in my library in the epic games launcher... but I was able to enable source control through plastic. It kind of worked. I have plastic for unity enabled too. I have a number of configurations including the local. When I attempt to add my project to source control live coding tells me that encryption is enabled on my server and my local configuration has not been given the keys (paraphrasing here).

I had some problems with one drive renaming my files and confusing the heck out of both me and plastic... it added my computer name to the end of every file. Once I rectified that I tried adding changes to plastic only to be met with that error about encryption keys and my configuration.

I currently cannot use source control nor compile. This is what I get when I attempt to compile:


Manual recompile triggered

---------- Creating patch ----------

Running ..\..\..\Engine\Binaries\DotNET\UnrealBuildTool.exe -Target="MYCPP_FPSProjectEditor Win64 Development -Project=""C:/Users/jacob/wkspaces/MYCPP_FPSProject/MYCPP_FPSProject.uproject""" -LiveCoding -LiveCodingModules="C:/Program Files/Epic Games/UE_4.27/Engine/Intermediate/LiveCodingModules.txt" -LiveCodingManifest="C:/Program Files/Epic Games/UE_4.27/Engine/Intermediate/LiveCoding.json" -WaitMutex
  Target is up to date
  Total execution time: 0.69 seconds
---------- Finished (0.000s) ----------


Let me state that this looks to me like a file handle issue; though I've quick restarted UE4 and shut down my IDE (VS 2022) multiple times attempting to let UE4 grab the project files so that I can compile, to no avail.


Above that I get like 100 messages in yellow text saying this:



Non-unique symbol _volmd found in COFF file C:\Users\jacob\wkspaces\MYCPP_FPSProject\Plugins\UE4PlasticPlugin\Intermediate\Build\Win64\UE4Editor\Development\PlasticSourceControl\Module.PlasticSourceControl.cpp.obj. Do not change the order of these variables while live coding, or consider upgrading to a newer compiler (VS 2015 or later)


Let me be clear I don't know what I've done wrong but it never seemed right to begin with 😭 I would appreciate any help!! 😅

Link to comment
Share on other sites

OH ! Hey I just realized there's nothing wrong with this other than source control (plastic) not allowing me to submit my changes due to the encryption config issue. Silly me! "Target up to date" means the compilation had been successful and won't need a recompile. Duh!

Link to comment
Share on other sites

Hi @DevDude,

Sorry for the delay. Are you using Plastic SCM Cloud? 

You will find the links useful:

1. Wrong Encryption key

2. Receiving the error on encryption configuration

3. How to create a encryption key


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...