Jump to content

Current workspace has not been initialized (VS2010)


Recommended Posts


A fresh bug-report from me again :-)

I have now made a solution folder stripped solution, since solution folders caused all sorts of problems with the VS2010 plugin, but I still have some nasty problems:

When I opened up VS2010 with a solution, I could not use the View -> Plastic views. If I tried I got an error saying "The current workspace has not been initialized".

I don't know if it is related, but I noticed that the Solution itself in the solution explorer do not have a source control icon, but I could right-click and make a plastic refresh, which then displayed a lock icon. This however, didn't solve the "The current workspace.." problem, but is a (minor) problem in itself.

I checked the bindings, and they all looked good.

I tried right-click "update to latest", but that didn't fix the problem.

The workaround I finally found was to right-click the solution, choose "check in" (even though there was nothing to check in). And then close the check in dialog (the top right X) without checking in. After that I could access the view.

So in summary. I can only use the Plastic CS2010 integrated views if I open a check in dialog and close it without checking in. I only have to do that exercise once every time I open a solution though.

Link to comment
Share on other sites

Hi soho,

thanks for the feedback, I ran your use case and couldn't reproduce it with the version (please check your Plastic SCM version).

Maybe Im missing something, or a step? Help us to reproduce it so we can fix it.

however, we fixed what your describing in version please review release notes at: https://www.plasticscm.com/download/releasenotes.aspx

I wait for your feedbacks,

Venlig hilsen,


Link to comment
Share on other sites

I tried to create a whole new repository, workspace and solution and could not replicate the workspace load problems, so it seems to be a problem with this particular solution.

I don't know how to supply more information. Is there some diagnostic actions I can perform?

A side observation, but maybe related, was after I created the test solution in it's own workspace and repository, I was unable to switch back the workspace in VS2010. In fact the "Workspace working info" panel shows an impossible combination of Current workspace, repository and branch (a branch not existing with the current selector for the workspace, also the solution path did not match the bound path of the workspace). I tried a lot of stuff to change the workspace back, including using the Plastic GUI, closing / opening solutions, the phony check in, choosing a branch in the branck view in the workspace I wanted to switch to.

What finally worked, was a restart of Visual Studio.

I really hope you guys can come up with a fix, because I'm almost using most of my time finding workarounds for the Plastic VS2010 plugin.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...