Jump to content

TeamCity integration


Recommended Posts

  • 1 year later...


I also want to ask about TeamCity integration. It is becomming one of the most populare CI solutions, and they have support for all major SCM systems. Besides the built-in support for more wide-spread SCMs, there are plugins developed for Mercurial, Git, Accurev, Vault, etc.

Do you plan to implement such a TeamCity plugin? I guess it would help to remove another obastacle for adopting your tool, which in all other areas, I've examined, seems like an excellent choice.

Link to comment
Share on other sites

  • 4 weeks later...


We are currently evaluating different SCM systems. We would like to switch from Subversion to a more capable SCM that supports better merging and branch handling. At the moment we are considering to use Kiln (which is nothing more that Mercurial packaged and integrated with FogBugz) but Plastic SCM is (still) my personal favorite. Now, the problem is that we already invested heavily in our build/CI environment, which is based on TeamCity.

So, TeamCity integration in Plastic SCM would be awesome!

Do you have any plans for supporting TeamCity in the future?

Link to comment
Share on other sites

  • 1 month later...
  • 4 weeks later...
Hi' date='

We're testing it right now and our goal is to publish it ASAP, if possible this week. It has been under testing for the last two weeks, but we're still working on it...[/quote']


I am TeamCity PM. Feel free to send any questions or problems with our API to teamcity-feedback[at]jetbrains.com.

Link to comment
Share on other sites


Any news on when TeamCity integration will be available?

We would like to switch to Plastic SCM, but can't do that without TeamCity integration.

EDIT: Oh! Just realized that there is a release with TeamCity integration... Wuhu, finally :)

Link to comment
Share on other sites

Hello once again!

This time with bad news; we got a problem... :)

I had managed to get TeamCity with Plastic SCM running. I could run all build configurations and builds were working fine. Now, after I had committed changes to Plastic SCM our TeamCity reports an error in all build configurations. Please, find attached the full build log.

Here is an excerpt:

Patch is broken, can be found in file: D:\TEAMCITY\temp\cache\temp9077574000929102814patch_125428


Failed to build patch for build #9 {build id=125428}, VCS root: repository "Davis5"

path "/"

branch "/main"

checkout "/main" {id=175}, due to error: Failed to create directory: D:\TEAMCITY\temp\plasticscm8155987221468607886catresult\e:\TeamCity\system\caches\plasticscm\plasticscm_-464822823310685238\build\davis5.msbuildtasks

jetbrains.buildServer.agent.impl.patch.PatchDownloaderImpl$1: Server was not able to build correct patch, most likely due to VCS errors, will try again.

at jetbrains.buildServer.agent.impl.patch.PatchDownloaderImpl.throwError(PatchDownloaderImpl.java:113)

at jetbrains.buildServer.agent.impl.patch.PatchDownloaderImpl.checkPatch(PatchDownloaderImpl.java:103)

at jetbrains.buildServer.agent.impl.patch.PatchDownloaderImpl.copyPatchAndCheck(PatchDownloaderImpl.java:64)

at jetbrains.buildServer.agent.impl.patch.UpdateSourcesPatcherBase.copyPatchToTempFile(UpdateSourcesPatcherBase.java:70)

at jetbrains.buildServer.agent.impl.patch.UpdateSourcesFromServer.updateSources(UpdateSourcesFromServer.java:62)

at jetbrains.buildServer.agent.impl.patch.UpdateSourcesBuildStageBase.doSourceUpdate(UpdateSourcesBuildStageBase.java:90)

at jetbrains.buildServer.agent.impl.patch.UpdateSourcesBuildStageBase.doRecoverableStage(UpdateSourcesBuildStageBase.java:58)

at jetbrains.buildServer.agent.impl.buildStages.startStages.RecoverableBuildStage.doLastAttempt(RecoverableBuildStage.java:112)

at jetbrains.buildServer.agent.impl.buildStages.startStages.RecoverableBuildStage.doBuildStage(RecoverableBuildStage.java:70)

at jetbrains.buildServer.agent.impl.buildStages.BuildStagesExecutor$1.callStage(BuildStagesExecutor.java:31)

at jetbrains.buildServer.agent.impl.buildStages.BuildStagesExecutor$1.callStage(BuildStagesExecutor.java:29)

at jetbrains.buildServer.agent.impl.buildStages.StagesExecutor.callRunStage(StagesExecutor.java:68)

at jetbrains.buildServer.agent.impl.buildStages.StagesExecutor.doStages(StagesExecutor.java:31)

at jetbrains.buildServer.agent.impl.buildStages.BuildStagesExecutor.doStages(BuildStagesExecutor.java:24)

at jetbrains.buildServer.agent.impl.BuildRunAction.doStages(BuildRunAction.java:65)

at jetbrains.buildServer.agent.impl.BuildRunAction.runBuild(BuildRunAction.java:48)

at jetbrains.buildServer.agent.impl.BuildAgentImpl.doActualBuild(BuildAgentImpl.java:250)

at jetbrains.buildServer.agent.impl.BuildAgentImpl.access$100(BuildAgentImpl.java:48)

at jetbrains.buildServer.agent.impl.BuildAgentImpl$1.run(BuildAgentImpl.java:223)

at java.lang.Thread.run(Unknown Source)

Caused by: jetbrains.buildServer.vcs.patches.UnsuccessfulPatchException: Failed to build patch for build #9 {build id=125428}, VCS root: repository "Davis5"

path "/"

branch "/main"

checkout "/main" {id=175}, due to error: Failed to create directory: D:\TEAMCITY\temp\plasticscm8155987221468607886catresult\e:\TeamCity\system\caches\plasticscm\plasticscm_-464822823310685238\build\davis5.msbuildtasks

at jetbrains.buildServer.vcs.patches.AbstractPatcher$1.fail(AbstractPatcher.java:93)

at jetbrains.buildServer.vcs.patches.LowLevelPatcher.readPatchStream(LowLevelPatcher.java:156)

at jetbrains.buildServer.vcs.patches.LowLevelPatcher.applyPatch(LowLevelPatcher.java:79)

at jetbrains.buildServer.vcs.patches.AbstractPatcher.applyPatch(AbstractPatcher.java:42)

at jetbrains.buildServer.agent.impl.patch.PatchApplierImpl.applyPatch(PatchApplierImpl.java:18)

at jetbrains.buildServer.agent.impl.patch.PatchDownloaderImpl.checkPatchInFileIsCompleted(PatchDownloaderImpl.java:83)

at jetbrains.buildServer.agent.impl.patch.PatchDownloaderImpl.checkPatch(PatchDownloaderImpl.java:93)

... 18 more

Following line is of interest:

Failed to create directory: D:\TEAMCITY\temp\plasticscm8155987221468607886catresult\e:\TeamCity\system\caches\plasticscm\plasticscm_-464822823310685238\build\davis5.msbuildtasks

That's not a valid path. Interestingly, there are two drive letters D: and E:.

D:\TEAMCITY is the location of our TeamCity Server. E:\TEAMCITY is the location of TeamCity's data directory. We moved the data directory to another hard disk. Our data directory is not a sub-directory of the server installation.

Could that be the problem?


Link to comment
Share on other sites

Sorry, I was not very precise in describing our problem.

We did not move the data directory yet. We installed TeamCity that way years ago. So, our problem with Plastic SCM's integration does come from any changes made to TeamCity recently.

I guess that it is a general problem when install location and data directory are located on different hard disks, meaning both locations have different absolute paths. And it seems that the error occur only when running a new build with pending changes. There goes something wrong when applying those pending changes to the server-side checkout cache, which is located at e:\TeamCity\system\caches; part of the directory path that can't be created.


Link to comment
Share on other sites

  • 2 weeks later...

Hi all' date='

This Team City issue is fixed in the current latest release, see announcements:





Was the bug inside PlasicSCM or inside the TeamCity plugin? The TeamCity plugin under "Continuous integration servers" on your download page still delivers the old TeamCity plugin with files from 28.02.2011 ?! I upgraded to PlasticSCM but still get the same error.

Did someone forget to upload the new plugin?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...