Jump to content

Plastic SCM server detected a system date alteration


Recommended Posts

I am using the community edition of Plastic SCM on an iMac running Windows 7. Setup went well and I was able to add my code, checkout and edit...

When I tried to check in, though, I got the following error:

Plastic SCM server detected a system date alteration. Plastic client can't continue and will be closed.

I didn't change the date. This all happened within one session of coding.

Any ideas?

Link to comment
Share on other sites


Really weird. It is a protection on the eval system but you should be using the CE license...

Did you install the plasticd.lic license file containing the Community Edition license?? If you do that you shouldn't have issues.

Please let me know asap so we can get this solved and you can continue coding...


Link to comment
Share on other sites

  • 3 weeks later...
  • 1 month later...

Max, hi,

After replacing your plasticd.lic file into your ..\plasticscm\sever directory, restart the Plastic SCM server.

If you already did that and still have an issue, don't hesitate to send me the lic file Ill verify it.

Ill PM you the email address to send your plasticd.lic file.


Link to comment
Share on other sites

  • 2 months later...


I have the same error message. During the day, I did change my system's date due to some tests I was performing on my code. When I switched back to the valid date, the Plastic error started.

I've rebooted my pc twice with no success.

I don't know what else can I do...


Link to comment
Share on other sites


Is there any way to know what type of licence we have? Since the person who installed Plastic is not here today, I logged in to our Plastic Server trying to find out what type of licence is installed, but I didn't find anything.

If we had to changge or migrate to the "Community Edition" licence, do we have to re-install everything?


Link to comment
Share on other sites

  • 4 months later...

Hi! I've had the same problem. Current server time could be changed.

Community Edition license is used for a period up to January 2012.

Restarting the computer does not help. License re-downloaded and replaced on the server - does not help.

What else could be the solution?

Link to comment
Share on other sites

Thank you for your reply. I have already solved this problem of reinstalling SCM.

In the server log file record of the license is dated January, when the evalution period ended. I installed the CE license.

Command "cm li" printed the following:

Plastic SCM license information:

* User-license information:

AnaDron			ACTIVE
kvic			ACTIVE

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...